Request: Shape Rotate Increments

Please tune the DOT and COMMA shortcut, it would make my day if i could rotate finer than 90°.
One could use the rotation alike the movement together with CTRL and SHIFT

I would suggest edit boxes under “Shape Move Increments” in settings dialog.
DOT 90°

If you hold the Ctrl key while drag-rotating, it locks to 5 degree increments. Shift + (comma) or (dot) is a 45 degree rotate.

I’ve just added Ctrl to do 10 degree increments, and Ctrl+Shift to do 5 degree increments. That will be in the next release.


Mhmm, my Lightburn 1.1.03 (Win 10, German keyboard) does not rotate at all on Shift + dot or comma. both work only solely

What is above your (comma) and (dot) keys? On my keyboard it’s < and >, so those are the triggered keys for Shift+(comma) and Shift+(dot).

That is the problem!
The < and > are on the very left of the German keyboard. I tried them and they rotate shapes 45°.
But i spend a lot of time nesting my shapes for cutting. Pattern parts for clothing have no 90° angle and have to be rotated just tiny angles to place them.
Moving shapes with the keyboard works perfectly using this settings: Arrow 1mm, shift arrow 10mm and ctrl arrow 0.1mm. Switching between keyboard and mouse, just to rotate the items a little bit and then continue moving with the keyboard is very uncomfortable and time consuming.
I do not like your suggestion Ctrl to do 10 degree increments, and Ctrl+Shift to do 5 degree increments, as you could just press Ctrl+Shift twice to have the same result as Ctrl.
Please consider using my suggestion 1.5° 15° 90°

Shift+Dot is already 45 degrees, and has been for some time, so I won’t change that, but the Ctrl+ versions are not set yet, so I have changed them to Ctrl+Shift = 1.5 deg, and Ctrl = 15 deg.


Using my German keyboard layout i am not able to use the Ctrl+Shift combination.

Would you mind doing it the other way round? Ctrl = 1.5° and Ctrl+Shift = 15°

Thanks a lot!!!

What do you mean by “not able to” - you cannot press Ctrl and Shift at the same time on a German keyboard?

Ctrl + “.” and “,” works, but Shift+Ctrl “,” and “.” does not rotate anything as there is “:” and “;” on that keys. Shift+Ctrl would work only on that very left key on my keyboard, as both “<” and “>” are on one key.

I’ve modified the code to check for the base key scan code, not the character it uses, so the Ctrl+Shift combination should work now regardless of what other things are on that key. I will try to get a new test build up and send you a link to try it, as I don’t have a way to verify this easily here.

1 Like

You are fantastic!
i just found that MS-Powertoys include a keyboard remapper that works for single apps! I could solve that issue by this, too.

But this would have to be done on every machine and Powertoys are not stable…
Your way is much better!

Just tried the test build and it works perfectly with the german keyboard layout! Wow!

If you have some spare time it would be a nice addition to be able to set the values in the settings alike for the movement:
2022-03-29 22_15_23

1 Like

Spare time is not something I tend to have a lot of, but I’ll log the request. :wink:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.