Resolution Issue With Surface Pro 7+ (2736 x 1824px)

I have been trying to use Lightburn on my Microsoft Surface Pro 7+ (2736 x 1824px resolution) but I’m having an issue with the resolution. I have tried fiddling with the Toolbar and Font size sliders but no combination fixes the issue.

The worst of the issue is in the Cut Settings editor window which chops off half of the cut colors on the left and half of the cut type(s) at the top. There’s also just a lot of inconsistent sizes between icons and text in the program.

I know this is a non-standard resolution but it is the default for many of the Windows tablets which I know a lot of us use for Lightburn since it’s much more convenient as we can easily carry it over to the laser.

I have also tried setting the tablet to use more common resolutions and messing with the display scale but I still can’t fix the resolution issue.


It looks like you might’ve adjusted the Font Size inside LightBurn itself. In Edit → Settings, you can slide the font slider all the way to the left.

LightBurn can take advantage of the normal font scaling within Windows as well, so if you want items in LightBurn to be larger than a certain size, that’s likely a better option.

Yeah I have tried moving the sliders to different positions but none of that fixes the problem. Here is a screenshot with both sliders all the way to the left. You can see it still chops off half of the cut type line.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.