Return to Finish Position

Hi and thank for your help.
What are the criteria to make this work? I have a Creality Falcon2 laser/engraver machine.
Under Device settings, I entered 0 for both X & Y values. Return to Finish Position is ticked green
After I entered the 0 values, I moved the laser with the “Pin” to top-right and clicked “Return to Finish Position” button.
After the next job the laser went to origin. Just to check I open “Device Settings” Pop-up and noticed that the coordinates to which I moved the laser with the pin, is entered. This means that is registers the coordinates but doesn’t go there.
I think it is important to mention that I have an Origen registered, Unfortunately the machine goes there and not to the Return to Finish Position.
What am I doing wrong? Please advise.

If I understand you, you want to set finish position?
Move laser where you want it and click set finished position in move window.
image

Thank you. This is exactly what I need and also I do exactly what you suggest. I have just done a short cut and after the cut it went to the position where the job started. I am totally dumbstruck.
I have: “Start From” set at “Current Position”.
I quickly checked. These are the last lanes in the Console: (Something tells it to go to X0Y0.)
M5
G0 X0Y0
M2

You did - in device settings. Disable finish position there.

And you might need to select “user origin” as start position if you use those manually set positions.

1 Like

(Coordinates & Origin - LightBurn Documentation)

1 Like

Thank you very much. This solved it and the laser went to the registered position after the job. Much appreciated.

When using “Current Position” mode, the laser always returns back to wherever the job was started from in case you have to run it again, since that’s the only way you’d be able to repeat it.

If using User Origin or Absolute Coords mode, the job will return to the specified finish position.

3 Likes