Returning to set origin after framing

Now that I have finally got my machine working with Lightburn I’ve run into another problem, hopefully much easier to fix.

I’ve watched a few videos and searched the forum but can’t seem to work out how to set LB so that after framing the laser returns to the user origin of the rear left.

My machine origin is the front left and I have a user origin set as the rear left. When I click “Frame” the laser frames the job (in this test a square) from the bottom left corner of the job and when it finishes in the same place the laser head stays put.

Is there a way to set it so that after framing the laser hear returns to the user set origin at the rear left of the workspace?

Also, possibly related but when I use the ‘move’ panel I can set the laser to go to X0, Y0 and it moves to the front left corner but when I hit ‘get position’ it reports as X0, Y1169.47

I can then select 'move to position X0, Y400 and it will correctly move to the rear left corner but when I select get position it reports X0, Y1569.57.

I have no offsets selected, as it doesn’t seem to effect function I’m not that phased but was wondering if there is a way to have it report the correct positioning when selecting ‘get position’?

That last bit is obviously way less important than getting the laser head to return to the user origin position after framing.

I can’t recall with certainty if there’s a way of setting finish position for framing. Try setting “Return to Finish Position” in Edit->Device Settings. I don’t think framing will use this value but it’s worth a shot.

The behavior is slightly odd.

As I recall from your previous post, you don’t have homing switches but please confirm.

Can you run your manual homing process and then immediate after run these commands in Console. Please return output:


Thanks for your help. You’re right I don’t have limit switches.

This was the output from your command:





Target buffer size found

[MSG:Using machine:MKS DLC32]














































































This was the move window immediately after “Go to origin”

Screen Shot 2023-10-22 at 1.44.45 pm

And this is after selecting “Get position”

Screen Shot 2023-10-22 at 1.44.56 pm

I think on a machine without home limit switches, “origin” is wherever the laser head is when you connect to Lightburn…unless you set a new origin.

I think.

Try first explicitly doing a “Set Origin” at a desired location before “Go to origin”.

What are the results of “Get Position” at that point?

The root of the problem seems to be the difference between Machine Position and Working Position but I’ve never seen this be an issue while using $10=0.

Don’t know if this is of any help. My Atomstack does not have limit switches. I manually place the laser head bottom left before switching on. After connecting to Lightburn I use move buttons to shift laser head to left rear. I have return to finish position set to that corner and the machine always goes there at the end of each job. I too would like my machine to default to left rear, but at present I have to use the move buttons after framing or if I stop the machine. It’s a pain having it working from the front as the gantry gets in the way of loading or removing jobs. Hope there is a way to remedy this.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.