Reversed image text

Machine: _K40 laser

Board: C3D

Firmware: _Received new board and running its oem firmware

Problem/ Question:
Hi everyone i’ve just installed my new C3D board today, and i’m having a few issues, whilst using lightburn,
1, Raster speed is slow, regardless of how much i increase it via LB, it stays the same,
2, If i set it to cut, the laser fires and remains in same place, and will only stop when i turn off the power to laser via wall switch.
3, maybe only lightburn issue, but when i import a file into LB even when set to top left corner,
The laser will start at some random point, i have tried orientation at bottom left no different, also the image it starts to engrave is a mirror image, ( text reversed etc ),
4, Which file type from inkscape to lightburn for laser use, as i have loads of designs i’ve used on old k40 whisperer, but will not work right in LB.
I hope this makes sense to some of you,
Thanks in advance

Reversed text is most likely from setting the origin to the rear-left, instead of front-left.

Starting at some random point means you’re using ‘Current Position’ instead of ‘Absolute Coords’. Read here: https://github.com/LightBurnSoftware/Documentation/blob/master/CoordinatesOrigin.md#coordinates-and-job-origin

When you say “raster speed is slow” - raster speed of what? (vectors or photos?) Photos have very dense gcode, and default Smoothieware can only process about 800 instructions per second, so if you’re engraving a photo with the defaults, your speed limit is about 80mm/sec. Installing the Cluster firmware and enabling clustered gcode output in LightBurn raises this to about 240mm/sec

What settings did you use, and what design were you trying to cut? Did it say anything in the console?

Hiya cheers for quick response. When i say raster i mean engrave ( fill ) i drew a circle task was line & fill, also done a box with text in. Line box fill text. Speed was set at 100mms then again at 450mms no difference in speeds. Will check absolute code tomorrow. Cheers

Forgot to mention if i set home position on Lb as bottom left laser still home’s itself at top left. Regardless of lightburn setting.

home and origin are 2 different things, and not necessarily the same point on the grid.

Unless LightBurn can figure out how to move those limit switches for you when you change the origin, this sounds like the correct behavior. :slight_smile:

You aren’t setting the home position, you’re setting the origin - they’re different things. For the raster speed, the config.txt file on the SD card that’s plugged into the board contains the firmware settings, and these include speed limits. It’s possible that your X or Y move speed is limited to 6000 mm/min (100mm/sec).

Hi cheers for that the Y seem’s fine but the X is slow, not sure how to change the config file’s or what to, get your drift on the origin location, off work tomorrow so will be fannying with it all day, try and get it dialled in.
Brian

Hi i have shown a video of origin in lb, but can’t figure out why i have to move the origin to the file to start, should this not just move from home position to the file location and start doing the job, rather than me having to move the origin cursor to that point.
Lightburn origin

I’ve already replied in the ‘constant disconnection’ thread, so let’s work through that first. I think it’s all related.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.