Right Clicking the Device Button specific set of commands

Hi, I’m having trouble with a development controller. Soft reset (Ctrl-x) does not work after hitting a limit when hard limits are set grbl $21=1). What seems to work is right clicking Device Button, then “Stop” button pulls grbl reset signal low). I’m trying to automate the process in firmware as a proper soft reset.

What are the specific commands right clicking the device button performs?

Thanks,
Tim

It isn’t commands - it disconnects from the serial port then reconnects.

Thanks Oz. Would I expect the same result by deselecting the com port and re-selecting the com in the com port drop down?

Two steps instead of one, but possibly the same outcome. I’m not sure if selecting “no port” actually disconnects though.

Can you post a screen shot of the button to right click?? I’ve right clicked on just about everything and no sub-menu comes up.

There’s no sub menu at all - it simply disconnects the device and reconnects when you right-click the ‘Devices’ button in the Laser window.

image

Thanks Oz! I’ll give that a shot.

(Edit: That worked like a champ! Thanks!)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.