Rotary Chuck Steps per rotation Problem

Firstly Good Morning from my first post, Thank You.

I am using an FST 150w and currently running LB 1.1.03. I have a Ruida RDC 6645G controller and am trying to use the Rotary chuck I purchased with the machine. I have this plugged into the Y axis controller. The rotary moves fine.

I have read through previous posts and have tried all the solutions, marking the chuck, setting the steps per rotation and then utilising the rotary tab within lightburn.

When I set all the parameters in the rotary tab and try and burn its does nothing. I have checked the rotary is enabled in LB and also confirmed it is enabled in the machine. I have read that it may be the hardware of the RDC 6445 and lightburn rotary not being compatible.

If i disable rotary I can then burn now lies the problem.

Anything I try and burn is approximately 28% to wide. I have tried burning a 20mm square and the height is 20mm but the width is 28mm. I have measured the dia of the object and inputted this to the rotary tab.

The only way I can seemingly rectify this is to reduce the width of the image by 28% and vertically invert to allow for it on the rotary.

Any help is greatly appreciated.

Many Thanks


1 Like

The basic configuration of the rotary is the same. The only difference occurs if it’s a ‘chuck’ type or ‘wheel’ (roller) type.

You didn’t mention…

The motor drivers tell you how many steps/rotation the motor takes. Read that off the switches. The placard on the motor driver will tell you the steps/rotation.

Chuck type rotaries rotate one rotation for the motor since it’s connected directly.

On a Wheel type you must compute the gear ration and the driving wheel diameter…

Mine is a PiBurn and is a wheeled rotary.

Translate the configuration to steps/rotation

2000 steps/rotation. The gear ratio is 2.5 * 2000 = 5000 entered in Lightburn
For a wheeled rotary you also need to enter the driving wheel diameter, 62mm in my case.


If you’re is a chuck you don’t need the ratio (it’s 1:1), but you will have to enter the diameter every time it changes so the machine can compute the ‘surface’ speed of the object.

Make sense…?

Assume ‘width’ is the X axes direction?

X axes being off is odd since the rotary doesn’t do anything with the X axes. It only modifies the Y axes computations to make it look like a Y table… You did select the Y axes…?

Don’t know what to tell you here… :frowning:

Good luck


@jkwilborn makes complete sense thank you. Will check now.

Still unsure why LB wont cut in rotary mode, it sends the file to the machine but doesnt start.

Thank you for your help.

Can you ‘send’ the code it to the Ruida and run it from the console?

The rotary settings should not have this kind of effect.

The rotary just looks like the Y axes, so none of the other things should be affected.


From what I see you say you are trying to use the Rotary chuck, but you have selected the roller. Select chuck then do your settings as required

I never could get him to tell us if it’s ‘wheel’ or ‘chuck’ type… :frowning:

I think I asked…


Apologies, its a chuck im trying to use.

Didnt get a chance to try what you suggested today @jkwilborn will give it a shot tomorrow.

Thank you

That’s ok, it’s common… we know you know what you have… :crazy_face:

It saves typing/explanation if we have more knowledge of what type you are using.


I knew I wasnt going mad lol

So I have checked the driver and set lightburn to 3200 steps.

Lightburn will send the file to the laser but wont cut it. The only way to get it to cut is to turn off the rotary and burn as if was a normal x / y design and its still stretched.

The picture is the outcome of trying to burn a 20mm x 20mm square on the rotary chuck. 20mm x 28mm

The only way to get a semi correct output is to reduce the overall design by a percentage, Anyone any idea why it wont burn it rotary mode ?

Many Thanks

Mentioned on an early reply that it didn’t make sense for the X axes to be off.

It is the Y which is 28 not the X, that indicates wrong steps/rotation or diameter setting…

That would effect the Y axes surface speed.

I would check that the lps is getting the correct signals from the controller. There are only a few…

Do you have a voltmeter?


1 Like

Y axis apologies.

Using a Ruida 6445S using the Firmware version shown.

Does anyone have any experience with this combination ?


So this was purely down to needing to update the RUIDA Firmware.

Once I upgraded to 26.01.16 which enables the rotary to use the Y axis it was up and running.

Just had to finalise the step count and is working a treat.

Thanks to @Dave01 for his link to the firmware updates.

Dave V Ruida Firmware Updates


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.