Rotary Circumference Bigger than Galvo Field = Cuts off what is off field

Galvo field is 160mmx160mm
I have the rotary dialed in perfectly and can mark parts as long as the part circumference is less than the galvo field width.
Let’s say the part circumference is 300mm and 250mm of it gets marked.
What I’ve tried:

  1. Leave the field 160x160 and center the items to be marked, hanging off the left and right sides.
    –Result: It only sends what’s on the 160x160 field and ignores the rest.
  2. Change the field size to 300 x 160 and center the items to be marked.
    –Result: It appears to rotate to the proper position and looks like it moves properly to engrave it, but but the laser is off-center to the left. I suppose I could change the center position to 150…
    So I’m not sure exactly how to handle this situation!
1 Like

my rotary can hold 80mm and my biggest lens is 200mm, will try this weekend, did you try copying the settings and set the field size to 300x300?

Following along I was up against same issue a while back didn’t figure it out. Splitting up the vectors and carefully repositioning is possible but prone to inaccuracy. There is no reason we shouldn’t be able to burn a rotating cylinder with a circumference greater then field other then software limitation. Maybe next update? Never tried it with the ezcad.
60w M7

Another thought: Steve, are you sure you are expanding the right axis? Most rotaries I know are Y, where X staying on the machine. That way you may command out of range position from he beginning and that locks the controller. Maybe you should expand Y , not X?

My rotary axis is definitely my X-Axis. Everything is working fine unless the circumference exceeds the field size.

I EDITED the existing “device” to expand the field size to 300 x 160 (from 160 x 160) and tried to mark. The movement was right but the laser was not emitting.
What I will try this morning is duplicating the “device” and save it with the larger field size. Exit and go back into Lightburn, choose that device and see what happens.
It might be that simply editing the “device” and trying it caused a glitch.

Seems that the best solution, software-wise, is as follows:
When rotary is turned on, a “ghosted” field is overlaid on the regular field (perhaps a different color) that is the size of the circumference of the rotary in whatever axis you chose. Then you position your artwork and go.
Until a software update, we can hopefully find a workaround.

We have a solution for this already. :slight_smile:

In your LightBurn settings, uncheck ‘Ignore out-of-bounds shapes if possible’, this will allow LightBurn to output graphics larger than your workspace when working with a rotary.

1 Like

Thanks for the reply.
I disabled this option and it seems to have fixed the problem.

I hope in the next revision :
When rotary is turned on, a “ghosted” field is overlaid on the regular field (perhaps a different color) that is the size of the circumference of the rotary in whatever axis you chose. Then you position your artwork and go.
Until a software update, turning off the out-of-bounds option should work.

1 Like

Which version of LightBurn are you using? The code in the most recent releases is supposed to be smart enough to check the rotary settings and not clamp along the axis you’re rotating around, since technically you can go around multiple times.

Edit: Apparently I did the check correctly for the frame window, but not for when you actually start the job. Fixing that now.

2 Likes

I am using the latest version 1.2.04.
Also, if you need beta testing, email me. I was a principal engineer at Universal Laser Systems for 24 years.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.