Rotary engraving -- skips too fast between shapes

Hello guys.
I am having a bit of a problem tryin to make a chuck rotary work for my k40-like machine.
It’s controlled by a MiniGerbil3 card, with a 40x50cms working area and an adjustable bed.

bought a Creality Rotary Roller hoping fo the best, but the MG3 was unable to move it unless the speed was set really low.
The original Creality stepper is BJ42D29-08V28 (Nema 17, 1 or 2 amps according to diferent souces, 1.8º)

I frankensteined the Creative rotary and installed an stepper described by amazon like this: STEPPERONLINE Nema 14 Stepper Motor 0.9deg(400 Steps/rev) 0.4A 11Ncm/ Bipolar 4-Wires

The operation seemed succesful, but we are currently facing a problem while engraving.

At the beginning of each shape, we are getting a small “tail”:


During the engraving proccess, I can see how the rotary engraves the first “O” normally, the it makes a fast jump to the start the second “O”. The problem is this jump is so fast, it makes the tumbler bounce back and forth when it stops. It makes me think this is what is causing the problem.

Any advice to reduce this jump speed would be greatly appreciated. (via lightburn or console settings would be greatly appreciated)

Thanks in advance,

Turn off Fast Whitespace Scan in the Device settings window.

Just checked and it’s been off the whole time.
Tried turning it on with 1mm/speed with the same result.

Another thing that might help is changing the $121 parameter to about 1/4 of its current value. This will give more of a soft-start to the Yaxis. X&Y are normally the same, so you can use the Xaxis $120 for reference when you switch it back.

I set up my Console with Yaxis Mode and Rotary Mode macro buttons. No worry about which parameters I changed.


Will try that as soon as I get home.
Thanks a lot

Another thing I just thought about is doing, if $121 does not help, the same to the Y Max Rate $111 parameter. If you change this one, I suggest you keep $121 at the 1/4 value. However, I am not sure how much changing $111 will affect the program run itself. Keep us posted on your results.

1 Like

Before changing anything, save the pristine configuration, in two places, via Edit → Machine Settings → Save to File … when you hose it up, this will allow you to load from file and write it to the controller. Put one somewhere you won’t write over it… :grimacing:

You can also adjust values here, it’s at a higher level

It’s laid out in the standard x, y, z format.

What makes most sense, as marked in red, is these are bit values… let Lightburn do this for you, then you won’t make the mistakes humans make and the reason for this type of software anyway… Don’t code much in machine language anymore… :man_shrugging:

The green are for each axes acceleration values…

With my PiBurn rotary, I have this exact problem… I have a machine settings file to change my acceleration and jump off speed on the Ruida to control this…

I don’t think grbl has an equivalent to the Ruida jump off speed… this is what speed the motor starts before any acceleration.

The problem seems to be inherent to wheeled or roller rotaries.

Lower you acceleration rate, doubt maximum speed is a problem. It has to use more acceleration to reach a higher speed in the least amount of time… so they can interact.

I wonder if this is the actual cause… keep us informed.

Good luck