Rotary help! Graphic not burning in the right place

So I was going to buy a 4 wheel rotary for my omtech 80w. I also have a fiber laser. I’ve never done anything on the rotary but, my fiber laser came with one. I hooked it in to my 80w just to see if it would work. The rotary looks like it works fine however. When I use the locater in lightburn to get everything lined up it looks great but when I actually engrave it’s outside of the limits that I marked. Is it the rotary because it’s the chuck rotary from the fiber laser or am I doing something wrong in lightburn?? The pictures are the top and bottom of the graphic then the video shows where it’s actually burning. Thanks.

It appears your video didn’t come through - perhaps try uploading to YouTube?

If you run a frame from LightBurn does the area appear right?

How did you set up the rotary? What procedure, what numbers…?


Yes it frames correctly

I plugged it in to my Y axis per manufacture instructions the steps were already saved in lightburn from using it on the fiber. The graphic was perfect and not distorted. No matter where I moved the graphic on the screen it wants to print in the same incorrect spot. I also entered the correct cylinder circumference in the rotary set up.

How is your ‘start from’ and ‘job origin’ settings?

If you ‘select all’, is the green square where you expect it to be?

Since the ‘preview’ will show you what the code will do, does the start of the preview show the movement that you see on the machine? Might have to slow it down to follow it.


Is this on a Ruida? Looks more like the fiber laser, but haven’t used it for a few months…


You’re quite right- I wasn’t reading carefully enough. I read fiber and assumed this was for use with a galvo. Ignore what I said!

I believe my origin was set to current position. I tried it from home but then the rotary just spins continuously and won’t stop. I even restarted lightburn and brought in a new graphic

Would you be able to attach your file so we can investigate further? If you don’t feel like sharing it publicly you can email with it and make sure to paste a link to this thread so we can find it.

I do believe Jack is on the right path here - you might want to try setting the Job Origin to Absolute

I can try that when I get home from work. I’ll update

I actually set mine to ‘user origin’, but you have to push the origin button when you get it initially setup on the machine.

I also like the the job origin on the center left. I can use the manufacturers logo to center align the mugs related to the handle.

You have to have the Y axes with enough ‘room’ to rotate both directions or you end up with a ‘slop’ error…


It appears it was an origin issue. I guess I don’t understand how that works. I was under the impression you could use any of them. But either way it works great now. Thank you all very much.

The modes are quite simple.

In absolute coordinate mode, the machine will move the laser head around the work area ‘exactly’ how you have it on the window in the ‘work area’ in Lightburn… The home or machine 0, 0 is also the machines origin or it’s absolute coordinate of 0, 0…

When you set a user origin that becomes the ‘origin’ or where the ‘green’ square is on your image. This becomes the ‘new’ origin for the machine to ‘relate’ to when it operates. Current position uses it’s current location as the ‘origin’ of the job…

There is also ‘job origin’ where you can select where withing the job it will originate the work… Notice where the green square is located when you change these modes…

Absolute is a little more difficult for most people with a rotary so most seem to use ‘user origin’ as I do…

It’s all ‘relative’… :face_with_spiral_eyes:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.