Rotary Help! Please?!

Morning All

I’m wondering if anyone can help me as I’m tearing my hair out here …

We have a Chinese yellow & black laser (we call it a 6040) with a roller rotary attachment and a Ruida controller.

We’ve used the rotary previously, fairly successfully but the images were stretching. We had corrected these by eye by squashing the image, but I decided we ought to work out how to do it correctly.

Last night I thought I’d worked out the steps per rotation by testing using a 30mm box. Initially it was very stretched but with trial and error I reduced it to the correct size so I engraved a vase, which came out beautifully. This involved an image that was on just one part of the vase, not the whole circumference.

This morning I thought I’d try something a bit more complex and go for an image that would cover a whole vase.

I’ve created my image to the exact number of pixels, so there’s no stretching involved before I import it in to Lightburn. I’ve then imported it in and tweaked the size, mirroring etc so it SHOULD be exactly the same size as the vase (circumference and height).

When I turn on the laser, it runs through it’s alignment and the rotary turns, but when I go in to Lightburn to set up the rotary (using EXACTLY the same settings as last night, on exactly the same sized vase) it’s all wrong!

When I framed the image it looked OK so I attempted to engrave the vase and got a frame slop error!
I’ve double checked everything with the image and it should all be fine (nothing outside the area, the size should be perfect) so I went to check the rotary settings…

The enable rotary slider wasn’t green so I corrected it and the rotary just made a nasty whirring sound but the rollers didn’t actually turn.

If I unclick to enable the rotary I can Frame the image, but it seems too big.

I double checked the settings for the rotary and they’ve all messed up, even in the original file that I used last night, so I reset them to exactly the settings that worked last night and tried again.

Again I got the frame slop error so pressed enter anyway and the laser started but the image is stretched!

At this point my vase is ruined anyway so I tried the 3cm box test again, using the exact same settings from last night on the exact same size vase from the file that worked (but removing the image that worked) and it’s way out! 26cm! I double check the settings again and they’ve changed, again!

It’s like it’s not actually storing the rotary set up data I’m entering and, as I say, if I enable the rotary, the rollers just make a horrible sound and won’t turn.

What on earth have I done wrong?!

I’m not terribly technical, I’m the creative half of our business, rather than the practical one (who can’t come and sort it due to continuing coronavirus restrictions in Wales), so would appreciate fully dumbed down responses please!

I’m using Windows 10 and Lightburn 0.9.14 (as I say with a Yellow & Black Chinese 100W laser with a 600 x 400 bed and a roller rotary attachment).

ANY help, gratefully received!

I am not sure… but I had this problem as well… once or twice.

What I did was:
Turn rotary switch ON in LB and turned the machine off and on.
(I wrote down the settings needed as well)

That fixed the problem here.

Are you using a seperate stepper driver for your rotary or do you use the y driver?
The reason why I ask is: most probably the max Amp of the stepper driver for the Y-Axis is higher than what your rotary motor is able to handle. Might not has anything to do with your problem, but could kill the stepper of your rotary in some time.

I’m not really sure …

I unplug the green connector thingy and plug in the green connector thingy from the rotary into its place.

Like I say I’m not very technical! lol

Well, that means you are using the same stepper driver which is most probably set up for a much higher A than what your rotary driver can handle. Can you make a photo of that black box where you connect the rotary to (the front where the tables are printed onto), plus a photo of the small DIP Switches on top.
If your rotary has a label on the motor, pls. make a photo of it as well.

That much, hopefully, I can manage!

And, just to add more confusion to the mix,

I decided to give up and so disconnected the rotary, with a plan to go back to flat work. I turned off the rotary attachment in lightburn and turned back on the laser, but there must have been some kind of communication error as the laser just wouldn’t return to normal.

Long story short, I went with the standard IT fix of turning everything off and on again, and then off again and the laser is now working normally (no rotary attachment).

This leads me to think that I had two issues:

1-Lightburn and the rotary were not communicating correctly
2-I did not set up the steps per rotation on the rotary correctly

I’m not sure how I managed to make one vase work perfectly but it may be my last!

Again, thanks for any help/advice/suggestions …

From what I can see from the picture, your Amps are set to 1,2A which seems to be OK.
Unfortunately I am not able to find a spec for the motor.
The Steps are 6400 which you should test for the beginning. If the ratio for the rotary is 1 it should be O.K.

When you stop rotary works in Lightburn, you need to switch off the Rotary switch in Lightburn before you switch out the laser and reconnect the Y Stepper. Otherwise the controller still believes it is in rotary mode.

I am so grateful for your help, and you must think I’m the dimmest person in the world (entirely possible), but I’m can’t even test it accurately.

I have a vase with a circumference of 310mm so I thought if I created a 310mm high rectangle and tried that it would give me some clue as to whether I have the steps per rotation anywhere near, but each time I try I get a Frame Slop error.

The only element on my design is the rectangle!

Any further suggestions?

I genuinely HATE the rotary set up!

OK … have worked out the frame slop nonsense!

I will have a play and see if I can make any sense of it!

Regarding the frame slop error, did you mark in Lightburn the option to work from current position?
Frame slop error on the ruida usually means you are trying to engrave outside the possible laser area.
Which could appear in this case because we are not able to do a proper homing. But work from current position should work. grafik
Or could it be that you have an object outside the bed area which is not marked as output?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.