Rotary Issue - First run perfect second very narrow

Hello! I recently installed my rotary (with the proper pulse settings and diameter) and the very first glass came out perfect. I then shut my machine down, disconnected the rotary and re-connected my Y-axis and disabled the rotary in the machine settings. I have verified this many times during trouble shooting.

I then hooked the rotary back up again and re-enabled it in lightburn and now the picture is coming out extremely narrow. When I frame the job it moves the cup properly and no issues, it’s just when I start the job.

The image should be about 3 inches tall and about 2.5 inches wide. It’s keeping the height properly just the width is not working right.

Thinking my Y-axis was off I even started my Y at about halfway. I am out of ideas. The attached image, you can see on the bottom how the image should come out, but in the top portion of it you can see how narrow it gets. If the file goes the full run its about a half inch wide.

To clarify the only setting that was changed between the attempts was turning on and off the rotor in the machine settings. Pulse and Diameter is still correct.

Thank you!!

Are you positive that the rotary mode is on again? This is a setting in the controller itself, so you have to be connected to the machine when you re-enable it.

I am…fairly certain, I have tried multiple times. I even tried to cut on wood without changing settings and it was all messed up until I disabled the rotary mode. Then turned everything back on again and same problem.

You said, “with the proper pulse settings and diameter”. Have you done a basic check to verify that? I’m wondering if maybe the rotary setting wasn’t on when you did your first test, and it happened to be roughly correct for some reason.

The simplest test is making a rectangle that has a height that matches the circumference of your object. For example, if you were engraving on a glass that is 4" in diameter, that would mean a 12.56" circumference. If you made a rectangle that was 12.56" tall, and ran it with the laser off, you should see the following:

  • rotary pauses while drawing the first horizontal line
  • rotary makes one complete rotation
  • rotary pauses as the laser draws the second line, exactly over the first one
  • rotary makes another full rotation back to the starting point

If it doesn’t do this, a setting is incorrect.

Thank you @LightBurn, I will give it a shot when I get back to my machine in a few hours. When I ran my first attempt I followed the setup guide for the rotary but I am sure somewhere I messed it up. Thank you for the help and I will report back a little later!

Hey @LightBurn, so I think we are good to go. I can’t prove it obviously but I believe that for some reason the machine just was not taking the settings. I opened everything up in rdworks and enabled/disabled the rotary, then I went back into lightburn and everything worked for me. I am about 99.9% certain that I was reading/writing correctly to start but who knows :thinking::rofl: The most important part is problem solved!

But then I did what you recommended and my rectangle was about 1/4 inch off. I think I have it all dialed in for now. I am sure there will be more questions to come!

Thank you very much!!!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.