Rotary issues on my openbuilds cnc

This is my first post on here. Ill keep it short.
I have an openbuilds cnc router running arduino nano controller with grbl 1.1h i believe. Has been cutting and engraving flawlessly. Until now. I added a chuck rotary.
Cnc has nema 23 drivers are set at 2.8amp 2b 400 pulse/rev. Xyz in controller set at 99.667steps/mm. Everything works.

Now add rotary….unplug both y motors. Wire in the creality pro chuck rotary. My settings are in steps/mm and rotary settings come up as mm/rotation. I can get everything to frame and move and the rotary test will do a full rotation.
Problem is when i run the file the X will make 3-4 passes befor the Y (now rotary) will rotate and consistently 3-4x to 1 y. Yet in the move tab i can move it .06mm and it moves every time i hit the button. It is only when sending the file.

The stepper on the rotary is a ceality 42-48 nema17 rated for 1amp.
Tested it on my roller style. Same thing.
Is it the driver settings? Too much power hurting it?

I have another driver on order to swap in when i switch back and forth if that is the issue

If you’re plugging it into the same stepper driver and ramming 2.8 A through it, you’re cooking the daylights out of it and it’s probably misbehaving.

You can wire the two stepper driver inputs (STEP and DIR) in parallel, configure the new driver with step/rev and current values appropriate to the (smaller!) rotary motor, and both motors will be perfectly happy forever more.

If you want to get fancy, you can wire a SPDT switch to the stepper driver ENABLE inputs so only the selected motor will turn. That way, you need not unplug the Y axis when you use the rotary.

Use LightBurn to save the GRBL configuration you use for XY operation, tweak it for rotary operation, save that, then you can load the appropriate config without having to think about all the details (and get them right!) every time.

1 Like

Spdt switch could work. My cnc Y axis has dual drivers dual motors. I like the idea of having a switch to toggle them. Can the one switch work for the 3 drivers? 2 on 1 side 1 on the other?

Y is cloned. I read that you can run 2 motors off 1 driver but i think it would be easier to clone the y with jumpers off the current Y driver to the new one then toggle like you say between them with independent harnesses so i dont have to unplug the motors. Just plug in rotary. Flip a switch. Load settings and go.
Sorry to seem like a noob. Flat lasering and routering is easy operating.
Config. Not so much lol

The general idea is that the stepper driver bricks have an ENABLE input that is active when it’s not connected, so the switch connects that signal to ground on the driver you don’t want running.

So you’d connect the + side of all three ENABLE inputs to +5 V, just like the STEP and DIR inputs, with the switch grounding the - side of ENABLE on the driver(s) you want to disable.

Yeah, it’s backwards, but that’s life.

You are very close to the heart of the matter … :grin:

So this one on the left then and the switch would have ground in the center and then the 2 steppers to 1 side and the rotary to the other.
Thats slick! I like it

Precisely!

Now, to be honest, I’ve never quite believed the way the ENABLE input is supposed to work, so don’t be surprised if it’s exactly the opposite of however you wire it up.

One other questin about microstepping. What would be a good setting for the driver that will run the rotary?

Edit. Just pulled a Y driver. It is set at 2.0a and 4 on the steps switch

Second edit.
Pulled driver. Switched it to 1a output. Tested. Still same thing. Turned off rotary mode and same thing. So it seems to be something in lightburn. Or my grbl controller doesnt like something.
If i turn the engraving 90* the rotary goes back and forth and the x moves .07mm each cycle of the rotary just like it should work. Just opposite how it should lol. Im pulling my hair out here


Heres the results of my testing. The line is from the stall and then jump. Happens every 7 lines. I cleaned it up a bit with 2mm added focus height and .07 intervals as seen in the one pic, its better but i can still see the lines. The lines are definitely not slip. Its too repetitive. Maybe i need tighter lines per inch yet?

If this is what you have:

Then it looks like a direct-drive chuck, with no gearing or belts between the motor and the chuck. Is that how it works?

That page touts the 0.225° “higher precision”, which works out to 1600 step/rev if it’s directly driven. Look that up on the side of your driver, set the DIP switches accordingly, tell LightBurn’s rotary config what you’ve done, and that should get you started.

A 100 mm diameter mug has a circumference of 315 mm, so each motor step moves the mug surface 0.2 mm. Your 0.07 mm step size is much smaller: the motor will not move until (about) three steps happen in any one direction and changing direction can absorb half a dozen steps without moving.

Because Creality seems to think 1600 step/rev is the right number, you should increase the scanning interval to match. This will depend on the diameter of the mug, so some computation is in order to get the right answer.

While you could increase the number of step/rev by changing the stepper driver switches, you’ll probably discover why Creality didn’t claim, say, 0.06° = 6400 step/rev: the mechanical design can’t deliver that level of precision.

1 Like

That all makes sence. Kinda. Driver is set to 3200 steps. The .07 interval works as you can see in the photo. But what happens is it moves each line just fine till line 6 then it kinda hesitates for a line. Burns the same line a second time. Then jumps 2 lines. And repeat. The new driver is capable of 6400 but wont make a difference then?
Yes it is direct drive

Thia test burn was done on a 249mm circumference water bottle.
It is working though! And very close. I just dont like that line and im not sure y its so perfectly repeated. Doesnt lose position or steps. Returns perfectly to the origin. Just pauses and jumps those 2 lines together. Goona double check speed and acceleration settings tonight. Might have those messed up aswell, naturally cranked them up when adjusting the steps but after some research it tells me more steps more pulses and the controller might not be able to run that many

Run the numbers: each step is 0.078 mm.

Starting from 0.0, the commanded position (“where you want it”) goes up by increments of 0.07 mm, but the physical position (“where the motor must stop”) changes by 0.078 mm. When the difference exceeds half a step, the controller must skip a physical step to bring them back into (rough) alignment.

Here’s what happens without that correction:

The difference between the commanded position and the physical position continues to grow.

So the controller skips a step every now and again:

What “skipping a step” means is that the motor doesn’t move and the laser will retrace the same line.

This happens whenever the line interval isn’t a multiple of the physical step size and has nothing to do with speed / acceleration / power. It will repeat perfectly because that’s how the numbers work.

The solution is to make the line interval a multiple of the step size, so exactly one or two or three motor steps equals one scan line interval.

1 Like

Thats amazing! And makes sence now. Thank you. This is a terrible picture. I guess ill have to keep playing with it. Trial and error.
Wonder if i can mofify this a bit and put a gear reduction belt drive assembly on it somehow.

Ill do a test burn with the 4 roller aswell tonight and see if it does the same or is smooth. It has a belt drive on it :thinking:

Got er all flanged up last night with the new driver and 3 way switch.
Pretty darn slick.

The new tb6600 has 3200 capability. Set the dips for 1.5a and 3200/rev. I played around with the settings a bit more and ended up with a focus height of 8.5mm 0.07mm line intervals. 5000mm/min and 55% power. Still leaves a super faint line but with the closer focus its way less noticeable without a camera zoom and the right light shining on it. Might back that off a tad yet on the power still. Will test a bit more with time.
Anyway
Ran 2 files on 2 different size/shape pieces and both turned out pretty great. A straight 249mm water bottle and a tapered 36oz mug 350mm at the top, 330mm above the cup holder part, with handle (had to get creative to clear the handle)
All and all a success!

Thank you ednisley for your help. You sir, are awesome!!



Huzzah!

Now that you see how the numbers fit together, you can get closer to the ideal of having each design work the first time.

Mounting a scratch tumbler is always a Good Idea™, though.

:grin: