Rotary not shown in setup options

I have the OMTech 55w Blue/Gray laser with the Ruida controller. I bought the Orion Motor Tech 4-wheel Rotary attachment shown in the picture. The rotary is setup on the Y axis. Opening to Rotary Setup window, I see the two options are the chuck style and roller style, but it is the other twin roller type.
I selected the Roller Style assuming that if I just input the size of my rollers, that would be enough. I did that and the diameter of my tumbler. The test run came out elongated in the rotary (Y) axis. My tumbler is about 100mm dia. In order to get the graphics aspect near to correct, I had to tell the setup that my tumbler was 180mm. This was just the result of trial and error.
How do I get this thing tuned in so I can accurately and predictably set the machine to get the result I want?
Thanks for your help.

This is from our older documentation, but should get you started: Documentation/RotarySetup.md at master · LightBurnSoftware/Documentation · GitHub

You’re correct that you need to use the roller rotary style, but you have to get the correct ‘Steps per rotation’ setting to use it, and once that’s set things will behave.

You enter the roller diameter, choose an arbitrary ‘Steps’ number like “5000”, then click the ‘Test’ button. The rollers should make one full rotation, pause, then return. If they go too far, you have the step count too high, and if they fall short of a full rotation, you need a larger step count.

Start there, and reply if you’re still having trouble.

1 Like

Thanks for the link. I had read through that already. Also, when I made changes to the steps per rotation setting, it had no apparent affect. When I hit the test button, the tumbler would make over 3 full revolutions. Whether the Steps Per Rev was set to 10000 or 100 or 1, even. Still multiple revolutions. When I get back to it, I will try to start again from scratch and see if I’m missing something.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.