Rotary not working correctly

Recently updated LaserBox and when I did, my lightburn rotary started to act strange. When I frame,my “Z” axis or “Y” starts to rotate about 5 revolutions too many before the 'X" axis works properly. I started to burn once and it just stated making long lines spaced out a mm apart. Ive checked everything i know how but nothing seems to work. It does work fine in Laserbox though.

Any thoughts would be appreciated!

2 posts were merged into an existing topic: Ortur Rotary - Y Axis Banding and large movements

yes, whats interesting is that it worked fine, but then updated my Laserbox software and my Xtool firmware then stared having the issues… so we know it has to be something inside Lightburn it doesnt like

Did the LaserBox update include a firmware update? If so, I suggest you examine for any GRBL configuration changes. Hopefully you have a backup of your original settings.

1 Like

yes i updated the firmware also, I dont know if anything changed or not though

Looks like this post may have the previous firmware revision config settings:

If you type $$ in Console you can check your current settings. Can you post to the forum?

1 Like

Wow! thank you! I will check tomorrow when I get home and post

1 Like






































Here are my annotations for changes that I noticed from the previous firmware:

$20=0; disable soft-limits
$21=1; enable hard-limits
$102=0; steps/mm on Z
$110=18000; max speed in mm/s on X, previously 12000
$111=6000; max speed in mm/s on Y, previously 12000
$112=6000; max speed in mm/s on Z, previously 12000
$120=2500.000000; acceleration in mm/s^2 on X, previously 1000

This looks like it could solve for some of the missed steps scenarios that people are currently seeing on rapid moves.

It’s not clear to me if this would affect rotary. Does the D1 use Z for rotary? I see that the steps/mm for Z axis was changed to 0 which seems an odd choice. I don’t know if 0 is some sort of reserved value with a special meaning in GRBL.

Your logic eludes me. You change two out of three parts of the software and blame the problem on the one you didn’t change…?

You should learn to do backups, more than likely a restore of the controller configuration would have had you back up.

I make a point of not changing any firmware, unless there is a specific reason for it and, if possible, I make a copy of the original.

Good luck with your machine… take care


Just for a test, open the Rotary Setup screen and turn OFF Enable Rotary. Then try and print something again.

Turning this off fixed the issue for me. I had heard it is a compatibility issue with some engraver boards. Hope this helps.


Your engraver is significantly different and better supported than the xTool.
I have my doubts about the efficacy of this proposed method here.

I just figured that the update on Laserbox is not compatible with Lightburn

Laserbox doesn’t interact with LightBurn. It’s only the firmware that’s relevant in this case. Can you confirm if rotary for xTool D1 is configured on the Z-axis?

Im sure it is, but how do i check?

In LightBurn, how do you configure the rotary? What axis does the rotary get set to?


Mine is doing the same thing–have you gotten any help?

I set up my RA2 pro today and had a devil of a time… Looks like xTool has some conflicting information . in one set up documentation is says to set the rotation per mm to 360… but on another setting for Light burn it says to set that number to 32… I read an off hand comment from someone saying they believed that the change occurred when xTool came out with the new RA2 pro… I set my settings to 32mm and it seemed to be a better functioning system… I then dialed in that number to 32.02 by making a rectangle the circumference of my cylinder and seeing how close the ends were or over lapped… 32.2 were very close if not right on each other.

1 Like

+1 and thanks for sharing! Setting the mm per rotation to 32.02 worked for me, running Lightburn v1.1.04 and firmware on the XTool is v40.30.003.01 B9.

1 Like