Rotary on U axis instead of Y axis

hi, I have modified my Omtech laser a bit so that I have a U axis with the aim of being able to connect my rotary to this U axis without having to lock the Y axis
I can move my rotary manually using the buttons, but if I want to laser, for example, the Y axis moves and not the U axis
What do I have to do so that the U axis moves when engraving?
but the Y axis stops?

Unfortunately, that’s set inside the controller, where changing it involves a firmware upgrade and some tweaking with RDWorks:

Unless you have that specific controller, do not attempt to load that firmware.

It may be that your controller already has that firmware, so fire up RDWorks and see if you can tweak the setting.

There is nothing about Y or U in the rotary area anywhere in rdworks
Also, mine is an RDC 6442G controller and I have no idea what firmware I should use

Then, AFAICT, you’re out of luck with the U axis rotary thing.

Which is a shame, because not gimmicking around with the Y axis wiring seems like a great idea.

Why can I still move the rotary manually using the marked buttons?
For me that means that lightburn can very well access the rotary via the U axis
Otherwise these buttons would not work and without a firmware update
and that even though the other arrows work correctly, that means I can move Y, move X and move Z

and that even though the remaining arrows work correctly, i.e. I can move Y, move X and move Z
in other words I can move X,Y,Z and U manually (with the buttons).
just not when engraving

Paging @johnjohn for a better answer.

This seems like it ought to be do-able, but Ruida controllers remain an undocumented mystery with very little hard information out in the wild.

It could be as simple as “nearly all lasers use the Y axis hack, so that’s what we support”.

My problem is that my stepper motor gets pretty hot and I don’t want to constantly have to change the dip switches (stepper drivers) so that my rotary doesn’t get hot. With the U axis you only need to do this once when making it

How can lightburn correctly control all axes manually (with the buttons)?
And why does the U axis have its own settings that can be read from the controller?

I tried that in the beging using the u axis but gave me trouble.
I went back to using the y axis what i did was add another stepper driver just for the rotary with a selector swich to switch from the normal y driver to the rotary driver and never had a problem one the driver was adjusted.

1 Like

How is that supposed to work?
Do I have to re-enter the settings every time, e.g. steps

I can’t say for sure, but some controllers are designed for other uses of the U axes and may not function they way you hope.

I heard a rumor that the 6442 was for a conveyor type movement between layers… that is the only control it has… it does make sense as you could move it from the console, but limited software control…

I have a 6442 and started to upgrade, I have the motor driver …

Turns out no one has been able to get it working on the 6442 and the 6445 has to have a certain firmware level to support it…

I decided with the state of Ruida information I’d quite wasting my time and use it as is… off the Y axes…

Motors are pretty cheap… maybe a low cost approach would be a replacement that is the same as your other axes…

My motors on the machine were very hot… never noticed until I was in there and about burnt my hand… Checking I found the motor drivers were factory set at two times their recommended current…

After the correction they just run warm… Might was to just double check…

Good luck


That may or may not be true for me, it makes no difference because it basically doesn’t matter whether I move a conveyor belt or a rotary with a stepper
Because in both cases the motor must be controlled and the full functions must be available in both cases, e.g. there must be an acceleration with rotary in order to be able to engrave precisely
on the conveyor belt so that the workpiece does not slip if the start is too abrupt. The same applies to the other settings

I think you missed my point. If the hardware/firmware is incapable of movement, except between layers it will never work.

There’s a zillion of these out there and I have yet to see a 6442 be capable of a rotary on the U axes… you can find plenty of people that have tried. I’ve read a whole lot of them…

I would never say you can’t, but I’d love to be able to do it myself.


I think we just need to rethink the programming of Lightburn so that all the many people can operate the rotary on the U axis. A lot has already happened in this direction, but there isn’t a whole lot missing in the programming

Again, it is not up to Lightburn. It’s the way the 6442 works…


that’s right
If lightburn knows how the 6442 works, lightburn can adapt so that the 6442 delivers the correct result

Have it your way.

Try RDWorks and get it to work with their software… That would eliminate the question.


So why did I and thousands of others pay a license fee?

and all this just for a bit of text (source code) that needs to be reformulated a bit, so thousands of people should be happy

In my experience, nothing is difficult for the guy who doesn’t have to do it.

1 Like