Rotary Ortur YRR 3.0 with Ortur Laser Master 3 - Connexion fails

Hello,

I am trying a new Rotary roller Ortur YRR 3.0 with my Ortur Laser Master 3, and have some problems.
When I turn the laser on, the roller turns about 1mn and the stops with the following message.
En attente de connexion…

[MSG:25:USB SERIAL STREAM CONNECTED]

Ortur Laser Master 3 Ready!

OLF:206.

OLH:OLM_ESP_PRO_V2.4B.

OLM:GENERAL.

GrblHAL 1.1f [‘$’ or ‘$HELP’ for help]

[ORIGIN:China]

[PRODUCER:ORTUR]

[AUTHOR:LEADIFFER]

[MODEL:Ortur Laser Master 3]

[OLF:206]

[OLH:OLM_ESP_PRO_V2.4B]

[OLM:GENERAL]

[DATE:20220920]

[SN:5F5FDFADC73C96118B75913B7EAB8D9F]

[VER:1.1f.20220325:]

[OPT:VNZHS+,63,32767,3,0]

Target buffer size found

[NEWOPT:ENUMS,RT+,HOME,NOPROBE,TC,SED,WIFI,FTP,TMC=7,SD,ITG,GT]

[FIRMWARE:grblHAL]

[NVS STORAGE:*FLASH]

[DRIVER:ESP32-S2]

[DRIVER VERSION:220327]

[DRIVER OPTIONS:v4.4.1-dirty]

[BOARD:Ortur Laser Master 3]

[WIFI MAC:84:F7:03:F7:C8:8E]

[IP:192.168.5.1]

[PLUGIN:Power Detecter v1.0]

[PLUGIN:Power Control v1.0]

[PLUGIN:gyroscope sensor v1.0]

[PLUGIN:Trinamic v0.09]

[PLUGIN:SDCARD v1.05]

[PLUGIN:ITG STREAM v1.00]

[PLUGIN:ESP32 WebUI v0.03]

[PLUGIN:GADGET v1.00]

ok

Projet chargé en 7 millisecondes

Échec de l’ouverture du port - déjà utilisé ?

[MSG:25:USB SERIAL STREAM CONNECTED]

Ortur Laser Master 3 Ready!

OLF:206.

OLH:OLM_ESP_PRO_V2.4B.

OLM:GENERAL.

GrblHAL 1.1f [‘$’ or ‘$HELP’ for help]

[MSG:20:Power Supplied]

ALARM:11

[MSG:13:Homing cycle required]

<Home|MPos:0.000,0.000,0.000|Bf:63,32764|FS:0,0|CL:0,0|PS:2,0|VA:24592,33|Ov:100,100,100|A:SFM>

[MSG:WIFI AP READY]

[MSG:WIFI STA DISCONNECTED]

[MSG:WIFI STA KEEP TRYING CONNECT …]

<Home|MPos:0.000,0.000,0.000|Bf:63,32761|FS:1131,0|CL:0,0|PS:2,0|VA:24581,30|A:SFM>

<Home|MPos:-39.950,-39.950,0.000|Bf:63,32758|FS:1131,0|CL:0,0|PS:2,0>

<Home|MPos:-79.970,-79.970,0.000|Bf:63,32758|FS:1131,0|CL:0,0|PS:2,0>

<Home|MPos:-119.980,-119.980,0.000|Bf:63,32758|FS:1131,0|CL:0,0|PS:2,0>

<Home|MPos:-159.990,-159.990,0.000|Bf:63,32758|FS:1131,0|CL:0,0|PS:2,0>

<Home|MPos:-200.010,-200.010,0.000|Bf:63,32758|FS:1131,0|CL:0,0|PS:2,0>

<Home|MPos:-240.020,-240.020,0.000|Bf:63,32758|FS:1131,0|CL:0,0|PS:2,0>

<Home|MPos:-280.020,-280.020,0.000|Bf:63,32758|FS:1131,0|CL:0,0|PS:2,0>

<Home|MPos:-320.010,-320.010,0.000|Bf:63,32758|FS:1131,0|CL:0,0|PS:2,0>

<Home|MPos:-360.010,-360.010,0.000|Bf:63,32758|FS:1131,0|CL:0,0|PS:2,0>

<Home|MPos:-400.000,-400.000,0.000|Bf:63,32758|FS:1131,0|CL:0,0|PS:2,0>

<Home|MPos:-439.990,-439.990,0.000|Bf:63,32758|FS:1131,0|CL:0,0|PS:2,0>

<Home|MPos:-479.980,-479.980,0.000|Bf:63,32758|FS:1131,0|CL:0,0|PS:2,0>

<Home|MPos:-519.980,-519.980,0.000|Bf:63,32758|FS:1131,0|CL:0,0|PS:2,0>

<Home|MPos:-559.970,-559.970,0.000|Bf:63,32758|FS:1131,0|CL:0,0|PS:2,0>

<Home|MPos:-599.960,-599.960,0.000|Bf:63,32758|FS:0,0|CL:0,0|PS:2,0>

ALARM:9

Défaillance de l’autoguidage. Impossible de trouver l’interrupteur de fin de course à distance de recherche. Défini comme 1,5* max_travel lors de la recherche et 5* lors des phases de localisation.

Ortur Laser Master 3 Ready!

OLF:206.

OLH:OLM_ESP_PRO_V2.4B.

OLM:GENERAL.

GrblHAL 1.1f [‘$’ or ‘$HELP’ for help]

[MSG:‘$H’|‘$X’ to unlock]

[MSG:3:Caution: Unlocked]

ok


The TEST button in the Roller configuratin from Lightburn brings the following message :pray: <Idle|MPos:-600.000,-600.000,0.000|Bf:63,32767|FS:0,0|CL:0,0|PS:2,0|VA:24592,30|Ov:100,100,100|A:SFM>
ok
Démarrage de flux
ALARM:2
La cible de mouvement de g-code dépasse la course de la machine. Position de la machine conservée en toute sécurité. L’alarme peut être déverrouillée. (Cliquez avec le bouton droit sur le bouton ‘Appareils’ pour réinitialiser la connexion)
En ligne ou quasi en ligne 0 :
Flux terminé dans 0:00
[MSG:Reset to continue]
ok
Ortur Laser Master 3 Ready!
OLF:206.
OLH:OLM_ESP_PRO_V2.4B.
OLM:GENERAL.
GrblHAL 1.1f [‘$’ or ‘$HELP’ for help]
[MSG:‘$H’|‘$X’ to unlock]
[MSG:3:Caution: Unlocked]
ok

I would recommend that you read the Ortur procedure for the rotary
By definition a rotary has no “end” therefore you must disable homing when connecting it

Hello Gilaraujo,

The homing is allready disabled (see joined file)

Homing is managed by firmware
Lightburn does not change firmware

Go to Edit → MAchine settings
Disable homing and click Write

Then it should be disabled

It is much better, thankyou very much

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.