Rotary setup malfunction

Can anyone help me out please. I’m not sure what I’m doing wrong. I believe I took all the necessary steps to setup the rotary attachment but the enable slider isn’t popping up. New to this so I’m sure I’m making a simple mistake.

I’m pretty sure that you have to select the Z axis for Xtool

I realize that it has been 5 months and I hope that you have figured it out by now but just in case you didn’t: You need to click on the “Edit” tab at the top, scroll down to “Settings” and click that then search on the list at the top, right side and the fourth toggle switch down is your “Show rotary enable on main window”. Once you toggle that then you will have toggle on your main window until you change this back.
I am brand new (today) to this forum that is why I haven’t replied before now.