Rotary Setup Problem since Update

Since the update I haven’t been able to use my rotary. I open Rotary Setup, enable and enter the settings. When I click OK nothing happens. My only choice is to cancel and, of course, it doesn’t save my settings. Please help.

Nice to know what version you are having issues.

What kind of rotary do you have, wheel or chuck?

With a wheel type rotary, once set it should retain the information. With a chuck type you need to tell it the radius/diameter for the object.

What are you expecting?

Do you have the rotary setup and the test fails?


I have version 1.1.03 and Windows 11. I have a piburn wheel rotary. I can enter the information but it won’t let me save it, the only button that works is cancel. It says: Error: Settings could not be written to controller.

How do you connect to the Ruida, usb or Ethernet?

I’d highly suggest Ethernet, it’s much more dependable.

Does the ‘laser’ window show that the controller is connected?

I have a PiBurn… Have you had it running or is this new? Make a difference how we troubleshoot things.

I’m questioning if you can connect to the controller… you can right click the ‘devices’ and it will try and reconnect.


I use USB. I’ve been using this laser, piburn, cable and all worked until I updated Lightburn. Now it says “no device found” at the bottom of the LB screen. Where do I right click “devices”?

The green arrow shows the communications status. The red is the ‘devices’ button.

Screenshot from 2022-03-23 09-46-43

What is selected in device type (blue)? Ensure this is set properly.


Thank worked. Thank you so much!!

1 Like

What worked…?

Others read these for help, ‘that worked’ doesn’t make the solution very clear. I’m wondering also…

That’s the payback… let other know what fixed it… :crazy_face:

You’re more than welcome, enjoy your machine… have fun

You can mark this ‘solved’… if that’s the case…

Best of luck with your machine… We’d all love you see your work…

Take care


Reconnecting the device worked. Now I am able to set rotary settings.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.