Rotary steps do not change moved distance, ...mostly

I did wade through a lot of how to set up the rotary before posting. Hopefully this has not been covered a zillion times. my apologies if so.
Hl 100W red and Black w/ RDC6445
I believe the steps were at 3000 steps as a default. It has the stock rotary that came with the machine. It is the same one as the image on the rotary setup window in Lightburn.
My test was to output a 100mm (y) by 50mm(x) rectangle. 3000 was way too much. It barely moved in Y.
100 steps = 71mm
200 steps = 71mm
300 steps = 71mm
400 steps = 71mm
500 steps = 2mm. Ok this seemed crazy so I retested. Same result. The data is being moved to the control. I am stumped.

Do you have a chuck rotary or a roller rotary?

Problem solved but the mystery of the crazy numbers not so much but who cares as long as it runs.
I found a video of my laser where they were setting the rotary up and they used 50550 for steps. I used that and it is really close. Who knows why the low numbers acted wacky.
I do have another question.
Under the Move screen in the Lightburn manual, There is Set Origin, Clear origin, Set finish position, and FocusZ. I only have Focus Z on my software. I assume that is because mt controller does not support the other commands? I really would like to have Set finish position if I could.

If the 50550 is close, adjust the number up or down to get it dialed in. Once you get it, it doesn’t need to be changed. All you need to change after that is the work piece diameter.

I only have the Focus Z, and I have a Ruida controller as well.

Thanks. I guess I will live without finish position.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.