Rotary steps off since updating to latest version!

Since updating to ver 1.2.01 my rotary steps are way off. My steps for my chuck rotary were 360 and now it spins past the start point many times.
The diameter of my part is 24.6cm or 246mm. I have a line drawn 246mm high and it will not start, stop and return at the correct position

It was working flawlessly before the update and I haven’t changed anything!

60w yellow and black 6040 c02 with Ruida 644XG controller

Also, I notice that if I click Read Settings, it successfully reads the settings and changes the steps value to 10000. I’ve restarted the controller, lightburn, the computer, and nothing will change!

Could it be a math error?


Oops I meant 24.6cm, lol but still shouldn’t spin past the mark like 8 times!

edited my original question

There is no way that on a Ruida controller your rotary steps were 360 per rotation. “360” is the default number in the LightBurn window when not connected to a laser, but as soon as the laser is connected and the settings are read from it, that value is replaced with what’s in the controller.

Are you using ‘Absolute Coords’ mode? You should use ‘Current Position’ mode when using the rotary, or it will first rewind to the origin, and since the rotary axis isn’t homed, it starts out at 10,000mm, which takes a long time to cover.

I know it worked flawlessly the last 5 times and then I updated the software. And I’m pretty sure 360 is what I had to change the steps to to get it to do a single full revolution afterwhich it was working right. Now it is doing a full rotation 8 times for a 246mm circumference. I’ve tried it on User, current and absolute.

So do I need to start at 10000 again and slowly adjust down from there?

I don’t understand what could have changed

I finally found a couple pictures I took when I finally got it dialed in a while back. One has the steps at 4100 and the other has the steps at 6000, not sure which would be correct. I am going to try one of those and see what happens….

Rotary setup is really pretty straight forward…

Whatever axes you’re using, read the motor drivers steps/rotation off the switches…

Match them up with the placard…

My setting is 2000 steps/rotation.

With a chuck type, you would use this value in the rotary gui.

If it’s a wheel type rotary, you need to apply a ‘ratio’ of the motor to the driving wheel.

Mine is 2.5 the motor will turn 2.5 times for the ‘wheel’ to turn one rotation.

Steps/rotation is 2.5 * 2000 = 5000 in the gui…


You will have to enter the wheel diameter, 62mm in my case.

For the chuck type, you will have to enter the diameter of each object…


1 Like

That is very helpful and takes “guesswork” out of the equation. I tend to overthink things and end up making everything harder on myself. Thank you for this very helpful and easy to understand information!

Thank you everyone for the help. Turns out the steps were 6000 and I’m back to having fun!

Glad that got you back up and running…

If you have to ‘fudge’ it any, modify the ‘wheel’ diameter… everything up to the motor rotations are digital… the wheel can vary a little…

Mark that as the solution, if that’s the case…

Take care, have fun


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.