Rotary: Steps per Inch having no Effect on outcome

I have a CAMFive laser with a chuck style rotary that was purchased used as a package. The laser has worked flawlessly for nearly a year; however, the rotary has been a struggle from day one with regard to image stretching (steps per rotation).
Machine Specifics:
• Laser: CFL-CMA6040K 80 watt
• Controller: Ruida RDC6442G –YM (Panel)
• Firmware: RDC-V8 .02.38
• Rotary: Direct drive (No belts or pulley’s) Chuck style with 1.8° per step
My machine has a direct rotary connection with a console button to enable/disable rotary. I have followed all of the advice on the forums with regard to steps per rotation (S/R) calculations, but to no avail. I have verified that diameter and pulse rotation settings from LB are being sent to the controller but as you can see in the illustration below, the results are identical with S/R settings of 100, 200 and 425. Note also that the length of the rectangle is set to 1.0” in LB but measure 2.125”.
Any help you can offer would be very greatly appreciated.

No Change

Hi, we were just looking in the forum according to same problem with Ruida 6445G and 6445GT5 we tried two machines and the result is same. Steps per rotation did not affect the lenght of rotation. We tried even two types of rotary device. Also changing between LB and RD Works did not worked. Any suggestions anybody?

I have gone through the LB rotary setup instructions line by line, including cycling power after inputting steps per rotation, and continue to get the same results. I’m at witts end. Please any help would be appreciated, from the Lighburn community and staff.

Are you saying you can not get RDWorks to successfully control the 2 rotary devices you have? Have you ever reached success using a rotary with these laser systems? This would indicate something other than just a software setting. :slight_smile:

Update: While I still cannot get the steps per rotation to accurately control the rotary, I have found a painful workaround. Once the object (image or text) is properly located and oriented, I multiply the desired image height by .4 making that value the height input. This yields a relatively accurate outcome. Example: Desired width and height is 3"x3". Calculated input is width 3", height 1.2"

Have you tried RDWorks to see if it also has the issue? If it does, then it could be the version of the firmware you have, or something different about your specific model (I haven’t seen the -YM version before).

Unfortunately, I have no idea how to use RDWorks. I learned with Lightburn.

your problem is a simple fix. you need to update your controller to the latest software version and that should fix your problem. i had the same issue

Can you provide a link to the Rudia download page? I don’t seem to be able to find it

The link is 下载中心-深圳市睿达科技有限公司. I tried installing RDWorks so I could update the firmware, but all I could get were communication errors and no support as to how to resolve the issue.

Any idea on how to get RD Works to communicate?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.