Rotary test not working with chuck

I was trying out the rotary test function. It seems it does not work properly with the chuck rotary. I have it dialed in and when engraving it does fine. I wanted to perform the test to be sure i had the perfect settings and when testing the rotary just moves 1" and returns instead of the full turn. I input the diameter of the chuck and same thing. Any ideas?

How many degrees is 1 inch?

I would say about 20-30. Dont have a way to measure degrees exactly.

What controller model do you have, do you know? (6442, 320, etc) I’ve tested this on my 6442’s and it worked, and other users have tried it as well, so I’m trying to figure out what’s different for you.

Hello … I’m having the same issue … Controller 6442 … Chuck Style Rotary 4 wire … set to 10000 steps per Revolution … Chuck Diameter 80 mm … the max it will go is 30 degrees …Y Axis controller is Microstep Driver M542-05 and toggle switches set to 5000 SPR … I did the Test in RDWorks … same result … so there is a setting I might be missing … I haven’t done a test on actual product yet to see what the outcome would be.


Have you ever set your steps per rotation before? If you set it to 20000 or 30000 does the test spin further, or no?

Hi Oz … yes … and I set it 30,000 and works like a charm … I’m just wondering if others have the Step Per Revolutions set at 10,000 and it works and others don’t.

Thank You for your Help ! :slight_smile: and for Really Great Support

Take Care and Stay Safe


6442, when i engrave it actually works fine but the test mode doesn’t seem to work.

I figured it out with the help of Chris. There are times where you must hit send file 1st, even though you have communication with the controller. Not sure why but i did this and the test function worked perfectly. Great tool to properly calibrate the roller or chuck rotary once it’s working.

That’s strange - it shouldn’t be necessary to do that. I’ll have to bug him to get specifics. Thanks for following up.

1 Like

Oz, any clue what’s going on? Now it won’t even work sending the file.

No, the code is pretty simple. It writes the rotary settings to the controller, then frames a ‘fake’ file that is 30mm wide and a height computed from your rotary diameter, so it should end up sending exactly the number of motor steps required to do one spin, then return back to the start.

Do you have a job paused on your laser or anything like that? I’m making a change to update the status display if the settings don’t write properly, so that might help.

No, nothing. We were able to get it working once then it would just not work… but when i engrave it works fine. Weird.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.