Rotating the workspace view to orient it accordingly with my extended laser bed

Hi, I have seen an earlier post regarding this exact same issue, but since it has been already closed, I hope I’m allowed to reopen the discussion over the same topic:

I have my laser workspace extended with an extension kit offered by the Laser manufacturer, which makes a nice and big space for bigger items to be cut or engraved. I really love it. However, since the machine size/length is now double, it’s better to enclose the machine “sideways” and not in the original orientation. This makes the orientation in Lightburn less optimal and also the workspace (long portion from bottom-up instead of left-right) also not fit nicely in monitors.

In the earlier post I’ve seen the comment from the developers that since the coordinate system seems to be complex for some users, this request is not supported as it might add to the confusion. I get that.

But, for advanced users, or users who can understand the coordinate/axis system good enough, this really would make sense and be much appreciated!

Would there be any way, such a feature might be added, it could very well be hidden inside some “advanced features” with disclaimer about not changing the setting unless if the user knows what they are doing?

Thank You in any case!

I am not sure if this is what you are after, but there now is an option under the ‘Device Settings’ to swap X/Y output which will change the view from portrait to landscape orientation.

1 Like

Oh wow, thank you so much!

I believe this is exactly what I’m looking for, I’ll just need to check it does actually work with the machine properly, too.

The old post I’ve seen must have been so old that such a development was already done meanwhile. Also, since I thought that as a setting it has nothing to do with the machine itself (simply a view-topic in the tool), I did not figure out to look in the machine settings.

Again, thanks a lot. I’ll confirm here later if everything checks-out!

Not exactly true. You rotated the machine 90 degrees, so it actually was a “machine setting”.