Rotation/Shifting of raster image when not boxed out before a cut

Currently running my laser with Cohesion’s Laserboard and Smoothie. All belts are appropriately tensioned, steps calculated, mirrors alligned, and material secured to the bed.

I have been tying, with no avail, to cut images out along their outer most edge so that I can use the most of my materials.

My Process: I first import the image, use the built in trace image tool, delete the original image, select the trace and un-group it. I then select the outer most vector duplicate it and assign the duplicated vector to a cut layer. I then align the cut vector layer with the image vector layer so that they overlay one another. I then assign FILL for the vector image layer and LINE for the vector cut layer. I set both to output.

This is what I end up with if I first fill and then cut. Origin bottom left of image.

This is what I end up with if I first cut then fill. Origin bottom left of image.

It doesn’t seem to matter if I select absolute location, current position, or user origin the output is the same. I have also tried homing between the raster and the cut by outputting them one at a time with no difference noticed. I tried updating LightBurn, re-flashing firmware, and checking my config file. Here is what the image looked like when viewed in LightBurn’s preview.

I thought at first that maybe my x-axis stepper was skipping steps during the raster, so I reduced the speed and acceleration. That didn’t help. But then I got to looking at the image and it seems like the image is rotating. As the raster progresses it moves farther and farther to the left (See second image: the head is much farther off the cut than the feet).

The only thing I have found that works is when I import the image, use the built in trace image tool, delete the original image, select the trace and un-group it. Then select the outer most vector and assign it to my cut layer. Because I removed this layer from my image layer, I am left with the inverse image. To combat this I create a box around the image and assigned it to my image layer. I set both layers to output.

Origin Bottom left of image.

No speed or power settings were changed between any of the above images. The only change was to box out the image and not have the two outer layers overlapping. I feel like I have checked everything mechanical that I can think of.

Any help would be greatly appreciated.

That sure looks like yet another case of a machines acceleration settings being too high.
I’ve seen it myself on my machine and read similar cases several times here on this forum.
Acceleration is too high and steppers lose a step or 2 on each pass.

I’ve got a flashlight here engraved with my name that looks just like that with each line offset just a tiny bit in one direction from the previous line.
Steppers aren’t keeping up with the demand…

Thank you for your reply @Hank.

I thought the same, so one of the first things I tried was adjusting the speed and acceleration. It didn’t seem to make any difference for me. I am using bidirectional scanning and it seems to be offset by the same amount and direction every time.

Also, why does it only happen when not boxing it out? It works perfectly every time I place a box around the image. Wouldn’t you expect the boxed image to gradually shift also?

That looks like it’s skewing when you scan. You’ve said nothing of the speed you’re running this at - How fast are you going?

The skew appears to be perfectly consistent, which makes me suspect you have a polarity issue with the step signal to the motor drivers, but you said LaserBoard, which has the drivers built in, and the config file pre-set.

Try this test:

Run 5 squares, on 5 different layers, at 10mm each, with low power and the only difference being the intervals on each layer. Use the following interval values: 0.25, 0.20, 0.15, 0.10, 0.05

If the squares with smaller interval values skew stronger, then there’s something weird with your motor driver config - you likely have the step signal inverted.

That wouldn’t explain why boxing it out solves it, but strange things happen with these.

Issue solved! I was using an external driver on both x and y-axis. I unhooked the external x-axis driver and plugged the stepper directly into the LaserBoard’s onboard driver, and voila, the machine now runs perfectly.

The speeds I had tried ranged from 50-100mm/s.

Thank you @LightBurn for the help!

You can use an external driver, you just have to configure the stepper pinouts for it. Putting a ! after the pin number will invert the output.

So instead of:

alpha_step_pin                               2.0

You’d use:

alpha_step_pin                               2.0!

Inverted the alpha_step_pin in the config file by placing ! as explained above. Rewired my external stepper, and everything works as intended.

Thank you @LightBurn

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.