Ruida 6432G homes properly from controller, but homing from lightburn ignores limit switches

Hi all, I’ve just upgrades the M2 Nano on my chinese laser to a Ruida 6432G. Going through the configurations and and I’ve hit a small wall with homing.

Laser homes in the right direction (upper right corner), I managed to get it to auto-home on boot (thanks to: RDC6432g will not home - #6 by oddwick ).

So, my issue is as follows:

  • When I home from Lightburn, the laser ignores the limit switches.It homes in the right direction, just doesn’t stop when the limit switches are triggered.
  • But, and that’s the interesting part, when the laser homes from the controller, it homes correctly (both at boot and on manual axis reset) and stops at the limit switches, then does the correct offset.

Here is the vendor settings:

I looked though my Lightburn Device settings and don’t see anything that might help you. Wondering if there is some setting that is only available in a certain version of RDWorks.

Maybe @LightBurn can give us an idea on how the command to ‘home’ works via lightburn on the Ruida.

Sure seems odd…

Good luck


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.