Ruida 6442 displays connecting to controller

Just purchased a Omtech 80w r/b20/28. I installed tube and started mirror alignment when the controller panel stopped responding. I cycled power to the laser and no it just says connecting to controller. Nothing homes and display buttons do nothing when pressed. I have contacted seller which they sent out another display and controller not sure if new but same thing. Led 15 is on 12 is on dim , both limit switch LEDs are on and chiller 1,3,9. Tried reconnecting to lightburn with usb cable and it is not seeing it now. Any help would be appreciated.

Are you saying you swapped out the controller and you still have a problem?

If you’ve swapped out the controller, that only leaves power supplies. It sounds like it has power to the controller, you lights seem ok if the head/gantry is in the proper position to trigger the home switches.

Does the machines console show anything?


This is all the screen shows. I went out and moved the gantry off the homing switches and looked at the LEDs again and 12 which is link is still on and nothing is connected by Ethernet or usb.


I’ve never had the issue of the console not being able to communicate with the controller. That is the message you are getting. I’ve seen it before and it’s turned out to be the controller. I’d try at least, removing and reseating the cable/connectors between the console and the Ruida. They aren’t usually easy to get at.

Did the home switch lights go out?

Does it attempt to home or just sit there?

Is this the replacement controller/console? You did not answer if it’s the replacement or not.

It’s not a good sign that the Ethernet is showing connected, when it’s not.


This is what I have right now.The I guess new control and panel seller sent me hooked up to a new power supply I just purchased with nothing else plugged in. I tried to communicate with lightburn but it fails to see controller over usb. I was under the impression that all I needed was 24v and panel hooked up to get the display to at least load to be able to load parameters but all I get is connecting to controller. Seller wants me to try and communicate with rdworks but I’m Mac user and don’t have windows I’m at a loss.

As far as I know, you should be able to communicate with the controller. It’s pretty clear the console is not talking to the controller… Could be either that’s the problem. You have power, so that looks OK

The number 12 LED is on, indicating a hardware connected Ethernet, that I can see isn’t connected…

I’d talk to the vendor about it… I’m suspicious that you have some bad hardware.

You could disconnect the console and plug it into the one in your machine… If it works you have a bad console and probably a bad Ruida…


I have been back and forth with the eBay sell and all I get is update drivers but I can’t even get anything to connect to update it. Then I was told within two days a tech would call me and I waited. Now I’m supposably on a call back list for sometime in the next 2 days. Like I have a week to just seat and wait by a phone. While all this is going on I received a return label to send laser back to shipper. I don’t even have the box now after 2 months. This has been a nightmare.

I’d pressure them to replace the Ruida and it’s panel.

Mine says that when it’s first turned on, then it continues on. One or more of the pair isn’t working…

I’d tell the if they wanted it back to pay for the box and shipping. On my first machine the box was such poor quality it fell apart as I took the machine out. There is no way I could have repackaged it in what they sent it in.

Hope you used a credit card, that may make or break what they will do for you … credit card company usually do something… even if they ‘eat’ it.

One of the other users had problems, they sent her a new machine… she still has the old one…

Good luck


Curious if you got this issue resolved? I just got the OMTech AF2440 with the same ruida controller and I had that same issue out of the box. I haven’t heard from OMTech support in a week after sending them several videos and pictures of voltage checks, status lights and wiring.

Yes mine is working now. Bad controller.

1 Like

It’s always nice when you find a solution to post it… and mark the thread solved.

This allows someone in the future to solve the issue quickly by looking at the post with the solution…

Take care… good luck


I also had a bad controller. Glad you got it fixed. Looking at some of the posts on facebook it seems like there is a bad batch of Ruida controllers with the same issue. No rhyme or reason other than a bad controller on a new machine.

Have the same problem, but my is 6445s. After 2 months controller stop working. Can u say how you resolved problem?