Ruida 6445 - getting really jagged cut quality

Got a new dual head recently. Manufacturer half-assed a lot of things, probably didn’t test anything. Second laser wouldn’t fire on any file sent. It had a 6442s in it, but the RD8888 password wouldn’t work and no other password we could think of would either. Manufacturer is adamant it’s RD8888. Nope.

So I got a 6445 to install to fix the problems and it worked! Except that the cut quality is now garbage. Jogging around on the corners like something is loose, but it’s all really tight. It’s brand new, so it shouldn’t be doing this, and it wasn’t with the 6442 installed.

I’ve lowered the speed settings on the machine by a lot, but it seems like there’s another culprit. The step length was REALLY off on both X and Y, maybe that had something to do with it? Any ideas?

Or does anyone have a 6445 that is working well currently and can share their settings?

Thank you!

That sure looks like something mechanical. Could the lens be loose in the holder?

More then likely you have something set up wrong for the steppers. Do you know which motors you have? What size is your table, not that it matters. My machine is a single head but pretty new so its possible we could have the same stepper motors. My machine is yellow/grey 150 watt (130 watt in reality)

I would also check acceleration settings - Lower speed is certainly helpful, but look here:


To me, this looks like the cut started in the lower left corner and progressed clockwise, which means you have bounce in the direction of the Y axis - you can see it very clearly when the direction changes from Y to X, and even more strongly here:

When the direction reverses in Y. The X axis is bouncing front to back like a guitar string. It is mechanical, and could happen if you have a very long X axis (like a 1400mm wide machine whose X axis isn’t stiff enough). It also happens if the Y acceleration is too high.

if it’s a new machine, make sure you have removed the protective grease from the rails, and replaced it with thin oil. like 3-in-1 oil.

the grease is there only to protect during transit and must be removed. i called the manufacturer and spoke with them to double check this essential point.

1500x1000mm, leadshine steppers. It may be to do with the step size. After switching to the new controller, it was way way off and had to be calibrated. It was working beautifully with the old controlller, so I may just reinstall just to note all of the settings and adjust from there.

Good call! I will do that.

I’ve dropped the settings low enough that this shouldn’t be happening… But yes, it is 1500x1000. The only other thing I can think of is switching back to the 6442 and copying settings.

1 Like

The 6445 is functionaly identical to the 6442. The settings you had in the 6442 should be transferable to the 6445. Before swapping out the controller I would try entering the settings you had in the 6442 into the 6445.

I fixed the problem by copying over the settings from the original controller, and then dropping the Y acceleration lower. Thanks for the input!


I was going to suggest plugging in your old controller and getting all the settings from there to transfer to the new controller. I literally just went through this last week when I upgraded my controller. I tried to back up my settings with rd works and reload them to the new controller but just wouldn’t work. I had to take pictures of each screen and then reconnect the new controller and manually enter everything. Eventually I got it figured out and was even able to tweak a few things. It was actually a good learning experience. Glad you got it taken care of, I know how that can be really frustrating.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.