Ruida 6445G v15.01.22 and rotary setup

Using Lightburn 9.22
Ruida controller 6445G with 15.01.22 firmware.

I just hooked up an rotary using a 3PDT switch to the Y axis and started to run test. When I enable rotary in lightburn (and verify on controller) I can jog and run frame on design and rotary moves fine. However when I hit start, nothing happens. Machine doesn’t move, or engrave and no error on controller. If I disable rotary toggle in lightburn and confirm on controller. Machine starts to engrave with rotary working. Any ideas what is causing the machine not to run when rotary toggle is enabled?

I’ve read that this firmware might send rotary to U axis. Can you confirm? Not sure if this is the answer. If it did wouldn’t framing the design also not work for me?

If it does go to u axis. Is there any instructions on setting that up?

Thank you. This is a known issue reported by another Ruida (Thunder Laser) member. We are investigating the cause, but yes, this may be related to the Ruida firmware changes to provide U axis support.

At this point, you have to ‘Send’ not ‘Start’. We are still trying to understand fully, haven’t figured out why yet, but it is on the list. :slight_smile:

The latest firmware does send rotary to the U.

1 Like

Hi Dave that was quite a certain reply so I presume you are up to speed on the most recent firmware. That so, can I ask what you might know about autofocus issues, if any, in that version of the hardware please :thinking:

If it’s pushing rotary to U axis wouldn’t it disable y axis when framing the design?

What issue are you having with auto focus? I have not had an issue with it with the v15.01.22 firmware.

I’m working with the Ruida CTO on some beta versions of RDWorks. Yes, the .22 firmware puts the rotary to the U axis according to him. I don’t have a rotary, so I can’t speak to the quirks of it. I’m not aware of any auto focus issues beyond it’s current inability to go beyond it’s 0 point. They are supposedly working on adding a parameter to let you go the other way beyond 0 by a set amount. Would make it easier for focus testing and setting your focus point deep for thick cutting.

I keep getting an error

#Getting Started:Auto Focus Question

If you could cast an eye I’d appreciate it. It’s something in action with support, but one more head is cool :thinking:

Just curious do you have the auto focus plugged into the 5v or 24v on the controller?

Ah it’s 24v Ruida 6445G

And did work originally

Shows up in the controller ui

Switches on and off when expecter

CN3 Lmt Z and GND

Gotcha, mine is the red one from cloudray and it has 3 wires to the focus switch and plugged into the 24v on controller.

yes its the pnp version I have one on order…

If you were to go to Getting Started…Auto Focus question

you wll see the last entries refer to an RDWORDS Lab question about this and what they did was to turn OFF Auto Focus and it worked… Now I think about it, mine was off when it worked and I set both windows th ACTIVE " YES"

Heres a quote
Post
by Joseph Abenhaim » Tue May 26, 2020 3:05 pm

Aaron Fuerlinger wrote:

Mon May 25, 2020 12:25 pm

I disabled Autofocus in the 6445 Controller.
Now for me it works well.
Give it a try.
If I Hit now Focus it drives the bed up to the switch and then lowers a little bit and touches the switch again. And Set the Focus without driving All the way down. I think I have seen the same behavior in one of russ Videos about autofocus.
Dang, that was it! Disabled auto focus in focusing menu and now it behaves correctly, pretty counter intuitive lol Thanks again!

So Yes tomorrow morning I am in there and will try combinations of entries in the Focus screen… Strange there are two windows in the same screen both asking to activate focus or not… as I mentioned I now have yes…but I simply cant remember if One was Yes The other NO…

I will kepp you updated tomorrow, the next thrilling episode :slight_smile: