RUIDA comms failed over USB, Ethernet, and Bridge

My controller has been unable to connect with any devices, and I’ve tried the following options:

USB: No comm port showing up. Getting the following error under Device Manager.
Unknown USB Device (Device Descriptor Request Failed)
USB was previously working until I experienced this issue.

Ethernet: I was using ethernet sucessfully over my local network after the USB failed, but then started to experience UDP transmission failure where portions of my file werent sending.
Then Ethernet connection stopped working from Lightburn. I’m currently seeing “Device Disconnected”, even though IP is correctly matched between Lightburn and Machine. Oddly, I can ping the machine over my network and it responds. It also shows LAN On on my machine display.

Lightburn Bridge: I setup the Pi Bridge and connected it directly to my controllers ethernet port. From lightburn, I ran the Bridge setup and the Bridge was found, but it’s showing “No Laser Connected”. Machine display is showing LAN On. IP is set to as instructed. I’ve also included the network and relay logs from the Pi web interface if that helps with troubleshooting.

lbnetwork.txt (151.0 KB)
lbrelay.txt (4.0 KB)

Not sure what to do at this point, I cant reach the machine any way I’ve tried. Could be broken? Idk, ever seen something like this before?

I have a Ruida RDC6442S-B Controller on a chinese imported laser (Gweike LC1390). Running Windows 10.

The only thing I can think of, is what I saw in the cabinet of my blue & white.

All of the electrical grounds are on one screw on the bottom right hand side of my back-panel (the panel on the back of the wiring cabinet) and the nut holding the 6 separate grounds came loose much too easily.

Power it off and wait a while… I don’t know if several hours would be enough. I would short a wire from the cabinet to the ground screw just to make sure the ground isn’t floating.

The next thing i would attempt is removing line-power from the LPS, the cooling pump, air assist/ compressor, vent/duct fan and the chiller ( if i had one ) and then try to communicate with the controller. If i got through, i would add equipment back to where it failed to communicate.

Line filtering capacitors age, and equipment can get noisier with age, and that noise can jam up the communication.

Those are the only two things that i can think of that would take down USB then Ethernet over time in that order.

One last thought - if the controller is more than 90% full of files it can jam up. It -shouldn’t- lose USB then Ethernet but it’s worth checking.

You can eliminate the cable by going from the Pi directly to the Ruida Ethernet connection with an open electronics cabinet. Both the Ethernet and USB ‘jumpers’ from the case to the controller are about as cheap as they can be.

The ‘Lan: ON’ indicates a hardware connection to the other device. Not that it can talk…

How are you able to do this…? I can only see the Pi bridge, not the Ruida which is on different sub net.

Have you cleared all of the programs from the Ruida memory?

Ensure you backup your configuration information before anything drastic… such as a factory reset…

Good luck


@JohnJohn Thanks for the tips. I’ve tried disconnecting everything you suggested, still no connection. Also checked the ground screw, it is on solid and the grounding is perfect, measured from case to outlet ground.

This was also my concern, that noise was the culprit. However, the machine is only two years old so I’m not sure if age would be the cause. Any suggestions for how to check on the filtering capacitors or where to look for noise with a scope?

I did a full format on the system memory, still no luck.

My suspician is that the memory of the controller was corrupted due to some power surge or static. I would like to try and reflash the controller or update it, but don’t know how to do that without a connection to the machine. Has anybody ever reflashed an entire controller unit?

Also not sure how to factory reset the controller, but I do have the machine settings saved so I’m fine with trying.

Just a factory reset of all the parameters within the controller. You can probably find firmware for a re flash, but since it was working, I doubt that will buy you much…

It should talk via Ethernet where you can use Lightburn to restore your saved parameters.

It’'s basically the same for all of these. Just need to know the password… here’s a cloudray video of 30 seconds…

If you can’t talk to it, it’s pretty much lost, I believe, but you can’t talk to it now…

Check cable and all before taking these drastic steps…

Good luck


@jkwilborn Tried the factory reset, no luck unfortunately.

Yeah it may have gone dark, cant get comms, no matter what cables I try, and I am directly plugged to the controller. Scary though, as I have no idea what caused this and would be quite worried about it happening to a replacement controller.

It probably was that it simply broke. That happens with everything. These controllers are pretty tough…

I plug my pc directly into the Ruida now and then, no router/switch, but you have to configure the com port to the right address (Ruida gateway) then you can connect directly to the Ruida. Doubt it will help…

Does the hardware still show it’s connected?

Good luck


Hi yeah im having the same problem worked perfect over ethernet ,now just says disconnected, if i plug usb in all is ok but why has ethernet stopped working?ive even tried going back to version 03 but no joy any help would be appreciated

The advantage of Ethernet is that there are no special drivers or anything that should interfere. Unlike USB which need specific drivers depending on the device.

The Ethernet status is on the controllers LEDs so you can see if it thinks the ‘hardware’ is connected properly.


Hi maybe a silly question,im running ethernet to a wifi extender plug which only cost 30euro i do have a raspberry pie just wanted to know the pros and cons for both?

The pi will be a much better option with the Lightburn layer of code to handle the Ruida communications.

This is the disk image.

Try the Pi, only need to load the image onto an sd card and run it… Mine come together pretty well.

It’s running 24/7…


Thanks for the information unfortunately my pi is very old and doesnt support wifi but will get one eventually,tha ks again for replying

Hello, wanted to share that I ended up replacing the entire Ruida controller unit, which did fix the problem, though I’d recommend this only as a last resort. No update on potential causes, Ruida did share that this sort of failure is quite rare.

I’m sad you had a failure in the controller. These machines are pretty tough, so I’m also surprised.

I’m overjoyed you have it fixed and running…

Take care