Ruida connection and LCD problems

Ok, finally took the plunge to change over my FSL P-Series 24x16 to a Ruida RDC6445S. It seemed to go ok, but now I’m a little stuck and not sure where to turn. The laser turns on, moves, cuts using Lightburn. But the LCD screen goes dark a few minutes after I turn on the laser and doesn’t turn back on. I can still get the laser to run, but no screen. I tested the cable and it seems fine. I tried a second screen and it does the same thing. Any ideas?
Also, I feel like I’m missing a software step somewhere. I ran RDWorks to get the drivers set up, then Lightburn can see and control it. But when I turn the laser off/on and restart Lightburn they don’t connect. I have to run RDWorks again and then Lightbutn can find it. Clearly that’s wrong, so what did I miss? Sometimes the controller screen just stays stuck on what looks like a boot-up screen, no matter what buttons I press or if it hits the limit switches.
I have the RDC6445S, connecting via USB, Windows 11, Lightburn 1.4. Device manager sees the USB connected on COM 3.

My first suggestion would be to get an Ethernet connection to your machine, either directly to your lan or via a wifi bridge… That will be one less headache.

Does the head appear to be doing a home operation?

In all likelihood you don’t have limit switches… You’ll have to advise… The Ruida has home switch and limit switch detection, but require 4 more switches to handle the limit inputs… One the Ruida homes, these switches are ignored.


I haven’t tried running mine with the console disconnected, but the OMTech Polar has a Ruida with no panel…

It sounds more like it’s a cable or the Ruida controller itself. If you’ve swapped out the console and there is no difference, it’s a pretty good bet there is a problem prior to the console i.e. the controller… Don’t know how you tested the cable…


Is this a new controller? I’d open up a conversation with the vendor… at least get it started.

I also have no clue how you could check which is the problem without swapping one or the other of them out…

Good luck with the console…

:smile_cat:

Update: I have another controller & LCD set (to do my other laser one day) and now both sets will turn on, but never get past the boot screen. RDWorks won’t see either one. Did I just get bad boards? Seems unlikely, but I’m stumped.

I justed mean I tested the cable with a multimeter and all the wire connections are sound. And yes, home switches, not limit switches. It starts to home (very slowly) but still never gets past the boot screen (see pic) whether it finishes homing or not.

I’ll probably contact the vendor next and maybe try ethernet tomorrow.

Both controllers won’t power up? Any error LED’s on the controller? I’m thinking bac control boards.

No error LEDs. Other LEDs work correctly - show when switches are hit, usb/ethernet connected, etc.

You can escape out of the boot sequence by pressing esc on the Ruida console…

Does it beep when you press esc?

If Lightburn can connect, you can read the controllers configuration. It’s very possible that it’s set up with slow speeds as to not damage a new installation… It may be programmed to home very slowly…


When it homes can you fake the homing sequence with the switches?

:smile_cat:

When I turn it on LEDs 6 (z+) and 15 (power) light up, the screen shows that loading image, and the head starts to home very slowly (like, you can barely see it moving). No beep when I press Esc. I get a beep for pressing Stop, but it doesn’t stop. Beep for pressing Reset, but no change - it still moves.
Faking a home by pressing the home/limit switches - the corresponding LED lights on the controller, but no other change - its still moving, same screen shows.

Connected via a known good USB cable, it shows in device manager as a USB Serial Port on COM 3. RDWorks says connection error, lightburn doesn’t see it using Find My Laser.

Same for both boards.

If I plug in an ethernet cable, LED 12 (ethernet connection) lights, but since I can’t get to a screen to specify an IP address that feels like a dead end for now.

I believe the stock Ruida lives on 10.0.3.3… and yes without a control panel you can’t change the IP…

If you’re ok with networks you can plug it directly into your pc… But you can break things, software wise, if you don’t know what you are doing…

Do you have a Z axes and was the light supposed to come on?


Can you see the laser in your device manager?

I assume you are swapping them on the same machine…?

Are you getting full 24V supply with ground to these?

Along with ensuring the console is plugged into the controller correctly, I can’t think of much else you can do…

:smile_cat:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.