Ruida, Connection issues after 1.4.00 update

I beg to differ… today it decides to do the same crash, while connected via LAN.

since the crash today:
-camera is missing
-can’t establish comms with my laser

multiple reboots of the os, lb and laser no help…
well, the camera appeared once in LB camera tab, but wouldn’t show in the work area of LB.

nobody has time for this

3 posts were merged into an existing topic: 1.4.0 Windows Crashes Every Time After Multi-Image

In that case try downgrading to see if the problem persists. This will narrow down whether indeed the issue is related to the version of LightBurn or some external factor.

I reinstalled 1.3.01 and have no issues to report. (simple download and install w/o removing 1.4.00)
I was able to burn and modify the very image that caused the hard crash yesterday.
This was via LAN, I wasn’t about to reconfigure something that works.

when 1.4.00 crashes, it takes everything down hard.

Was this issue reproducible? In the sense that burning the image would always result in a crash?

If so, can you upload the .lbrn file that would crash LightBurn?

Can you describe what you mean by this?

take a look through this thread.
when lightburn crashes, it takes down usb / camera.

Thats where I am now… Camera tab previews the camera, microsoft camera app shows camera video, but LB work area doesn’t show the camera.

everything works well until LB crashes. then I gotta spend a lot of time trying to figure out wth is going on… things work, then they don’t, work partially, then not.
One of the camera help threads talks about a driver for windows 10, but that file is no longer available (I was thinking it needed to be reinstalled (?) as there are apparently no drivers available)

There were a few minor issues before “upgrading” to 1.4.00… I was able to do what ever I needed, but now I cant even get 1.3.01 to work reliably.

I’m going to do a full removal of everything lightburn and go for a fresh install one last time.


installed 1.4.00 on a different drive after completely removing 1.3.01…

same as 1.3.01… camera overlay nowhere to be found, but it’s working just fine in the camera tab

Try switching camera to none, and then back to your camera.

I’m not following. In your last update you indicated that you had downgraded and that resolved all issues. Has something changed?

Are you saying that you’re now experiencing the same issues in the downgrade that you were previously experiencing in 1.4.00?

This implies that the issues isn’t necessarily something with a change in version but something else. Has anything changed in terms of hardware, OS, workflow, or the types of designs being worked on?

Sorry, I’m all over the map, because I’m frustrated and waste a lot of time not being productive and trying to find out why things are not working correctly.

I pulled LB off my computer, rebooted and put 1.4.00 in on a whim, on a different drive, suspecting some file(s) were corrupt(?)

It seems to be working now (~), for the limited things I’ve tried, EXCEPT the camera issue.
Camera image shows in the Camera Control tab, even displaying video while in operation, but LB does not show the camera image in the work area/overlay/background. Clicking on the Camera Icon on the top row doesn’t do anything, nor does the “update overlay” button on the Camera Control Tab… Soooo, for the time being, this is now more of a ‘camera’ issue than a 1.4.00 update problem… :face_with_raised_eyebrow:

Have you completed lens and camera calibration after the reinstall?

wasn’t aware that I had to… remember, same behaviour was experienced before removing/installing the software. I’m outta time today. maybe tomorrow… something I dread because the camera calibration process is … well, lets just say it requires a lot of patience.

I’m going by you saying that you completely uninstalled LightBurn. If that’s with prefs file then you’d have no reference to previous calibration.

If you still have your prefs file you may be able to load a backup of your calibration by going to File->Load Prefs Backup and picking a backup from prior to when this issue occurred.

However, it’s unclear to me where you are in this process with your various reinstalls.

Also, note that you can save just the camera calibrations/settings once completed by right-clicking on the Camera Control window and selecting Export Camera Settings.

you can’t make this ^&*( up…

I loaded an earlier preference, it brought back the camera. thanks!

however. I pressed the camera icon to refresh the overlay, and was met with an off-angle view…
it WAS correct before pressing the button… every time I click, the view doesn’t change.

looks like I’m going to do a full cal now anyway :confused:

lens calibration crashes LB
after trying some of the recommended changes in the camera thread (now closed) still no help,
in fact, it locked up my computer and had to reset power on the last attempt.

no other app on my computer has or creates such turmoil as LB :frowning:

What things have you tried?

What OS are you running?

Has anything changed either hardware wise or software wise recently? Are you plugged into the same port on your computer?

1 Like

There were some LB system camera settings to change, and I tried different USB ports

Running Win10pro x64 (22H2) (~ for memory, what ever the latest is)

The only recent sys/hdwr change was RAM, from 8gb to 16gb.

The Win system performance monitor doesn’t show any abnormal CPU or memory activity (~27% for memory)

Trying to calibrate the lens (the polka-dots tes) results in crashing… if I go with the pre-set camera option (I have the LB 8mp 85deg), I was able to get to the alignment and things went okay from there.

Is this the settings in Edit->Settings->Camera Capture System? Are you currently on Custom or Default capture system?

This is fairly unusual where you’d be able to otherwise use the camera but crash on lens calibration.

I’ve seen issues when USB cables have gone bad or when using an underpowered USB port. But generally that would not be isolated to calibration.

The times I’ve seen calibration go bad is if for some reason LightBurn gets confused with a particularly strange image capture. This was more common before honeycomb detection was introduced. Was that enabled when you ran the calibration?

When you first started using the camera with LightBurn prior to the most recent crashes, did you do a custom calibration or did you use the preset?

honeycomb was enabled

full camera calibration was done everytime before yesterday