Ruida Control 6445__? Slop Error - Can't set this up

I am experiencing the same problem. Without rotary setup in LB, the rotary chuck works in all modes with just the equipment switch (Y axis / Rotary axis). If I use the rotary setup in lightburn, the Y axis will operate for framing only. LB will not process the file to operate the laser. Downloading the file to the RUIDA 6445G control is sucessfull but no matter where I place the User Origin, I get “slop error” and no movement of the rotary device. User origin is in the middle of a 700x500mm area and my graphic is a 25mm x 3mm rectangle on a 76mm diameter wino glass. What am I missing.

Jack, both the RUIDA and LB consoles show a home position of x0y0 and a user origin of x346.3, y194.5. My A-axis is manual. The most interesting thing is the use of the LB rotary setup. When used, the Y-axis does not move. When not used, the Y-axis rotates as expected. To be clear, without the LB rotary setup, the chuck rotation does not consider the glass circumfrence or the Y-length of the graphic to be burnt. It seems like the rotary function of LB is not communicating with the RUIDA RD6445G. Has this been an issue with Ruida for other people?

My apology, “A-axis” should have been “Z-axis”.

My setup for a Ruida has the Z axes grayed out, likely because I have a 6442 controller.

I thought we were talking about the PiBurn setup?

A roller rotary, like the PiBurn has no need to know the circumference.

A number of people seem to have setup problems when first using a rotary or a specific type. I have not really seen a bug in Lightburn that I can remember. If it isn’t a configuration issue, it’s usually operator error or a hardware issue.

You can use the site search for a rotary and see the high number of hits… Most people use the U axes on a 6445 rather than the Z, but I have no experience using various axes with various Ruida controllers. On mine, I just swap out the Y connector…


I have a rotary chuck. My CO2 has a manual Z and a toggle switch for the Y axis that changes the Y output from flat bed to rotary. LB operates the Y axis in flatbed mode without problems. It will operate the rotary chuck for framing only when I utilize the “rotary setup” function. It will not perform the burn function of the file. The X axis will move and fire the laser. However, the Y axis will not move. Do you know of another LB user with a RUIDA RD6445G controller that I can contact. They may have solved this issue. The manufacturer has nor been helpful.

Jack, I tried to get this rotary chuck up and running several months ago and failed. I am revisiting it now because I want to expand my portfolio to glassware. I got a lot of feedback on my first attempt but nothing solved the problem. Could the LB file for the rotary operation be much large than a flatbed operation assuming the graphic and sizes were the same? I have “send” the file to the RUIDA as well as saved it to a jump drive and inserted it into the laser controls. It always acts the same. Could the file be too big for the RUIDA or possibly the Y-axis controller? LB will not operate the process directly.

It’s likely it’s working as designed… Something in how you are setup is causing this.

If you would answer some of our questions, I think we’d get this solved or at least get the right people here.

If you’ve gone through the setup, it should work with the test button.The roller should rotate one complete turn and back. On a chuck, the whole chuck should rotate one complete rotation and back.

… does it?


Jack, I have the chuck and it rotates 4.5 turns when I use the “test” button in the “Rotary Setup” screen.

Is your chuck a direct drive or does it have a belt and pulley?

What do you have for steps in the rotary gui?


It is direct drive. 12800 steps. I have used 6400 steps also with the same results.

You really can’t guess with these. It should be whatever your stepper is set for, as long as there is not a ratio between the motor and chuck.

These need to be set properly or we’ll be chasing our tail.

Did you follow the link on setup?

Can you take a screenshot of the rotary setup gui after you ensure it’s setup…

What does your console say?


I don’t have this device. I recall that there were changes to the Firmware to get the Rotary to work.

Which Firmware version do you have in your Ruida Controller?

  • This link may provide some valuable information.

Go to Edit > Get Controller Info, copy and paste that info here please.

Redsail CO2 laser, Mfg: 04/2021, Model: X700, 80-watts
RUIDA RD6445G controller

Try connecting the rotary axis to the U-Axis output of your controller. I suspect that is where your controller is sending the output when rotary is enabled.

Then follow the instructions in this post:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.