Ruida Controller - Machine ignores homing sensors


I’m running into a homing sensor issue that I can’t figure out. I’ve searched these forums for a while and tried a few things I’ve seen, but still haven’t gotten it working.

Here’s what happens:

  1. I click home on my Lightburn interface
  2. Machine homes to top right corner
  3. It ignores limits and crashes into frame

Here’s my setup:

  1. Ruida RDC6442G
  2. Limit switches are Fotek PL-05N (normally open)
  3. Limit switches wired to X Limit - and Y Limit - on controller
  4. Machine origin at top right

Machine settings:

What I’ve tested:

  1. Hand holding limit switches to metal frame [they’re not currently bolted in place] (they light up, and diagnosis screen on machine confirms they’re working)
  2. When I click home, I’ve put the limit switches against metal - they light up, but machine doesn’t stop homing.
  3. I’ve tested various settings with Limit Trigger, Limiter Polarity and Direction Polarity, but nothing seemed to help.

Any insight would be appreciated!

What’s the history of this controller? Was it working previously?

Also, how have you wired the switches to the controller?

I don’t think you want limit trigger enabled… This is for limit switches and doesn’t have anything to do with the home operation. It should not generate any error or cause the machine not to boot, that I know of.

Mine homes before it does anything, only then will it look at the machines limit switches. Although not clear, there is a home operation that has to complete. After it home properly it will ignore the home switches and watch the limit switches.

I doubt you machine has limit switches, just home switches. Limit switches are wired to the + terminals, both ends of both axes need switches for limits. The X axes limit switches are wired to LmtX+.

My machine origin is left/rear.

What error message does the Ruida console display?

I bought the machine used. I have not seen the homing operational - I’ve just been working through different features and fixing things. General laser features work, just not homing.

Here’s an image of my controller wiring. (I know it shows wiring to the X/Y + (plus) ports, but I have since changed this to - (minus) ports)

Ah, okay that’s good to know. I think I assumed the limit trigger enabled was related to the only homing “limit switches” that I was aware of on the machine. To my knowledge, there are only the two Fotek ones for homing that I’ve described.

I will turn off the limit enable and let you know what happens.

I need to double check the error message on the display, but I’m pretty sure I remember it showing: “Hard Limit Prot”.

Another side note: There is a setting in Lightburn for “auto home” on startup. I have this shut off due to the issues I’ve had.

1 Like

This probably occured when you had the limits enabled and the switches wired to the + inputs.

It shouldn’t detect this until it completes a home operation, at least mine doesn’t …

We’ll be waiting for the results…


Okay, I’ve turned off the Limit enable for both axes, and was getting essentially the same results: no gantry stopping with switches in contact with metal. (no message or beep when switches were closed)

I tested two things:

  1. Closing switches after homing was started
  2. Closing switches before I clicked homing button (this still allowed gantry homing movement to occur)

Both results were the same - no gantry stop and no message on machine display.

I’ll have to think on this…

Lets see if @ednisley recognizes anything here…

Hang in there…


Let’s try something obvious:

  • Disable both X and Y axis homing
  • Turn off the power
  • Unplug the four wires from the X axis stepper motor driver to the X axis motor
  • Mount the X axis switch in its mounting holes over on the right side of the gantry
  • Turn on the power (no homing will happen)
  • Verify the switch lights up when you hold a steel blade over the target on the top
  • Verify the controller’s diagnostic panel shows the X- input is active with the blade in place (and not without it)

That will show the switch is working and the controller is using the proper polarity.

If the switch signal does not make it to the controller, something is wrong.

If the controller thinks the switch is active when it’s not, set the controller to use the other polarity.

Because the X axis stepper motor driver is disconnected, you can move the laser head by hand, which is normally impossible / extremely difficult.

  • Verify the switch lights up when you shove the laser head all the way to the right
  • Verify it does not light up when you shove the laser head a few millimeters to the left

That will show the laser head can trigger the switch at the far right end of its travel, where it will be during homing. If that does not happen, then figure out why the laser head does not trigger the switch.

Assuming the laser head triggers the switch:

  • Turn off the power
  • Plug the X axis motor back into the driver
  • Turn on the power
  • Enable only X axis homing
  • Poke the RESET button on the controller
  • Verify the laser head moves to the right (toward the switch)
  • Verify the switch activates when the head reaches it
  • Verify the head backs off, activates the switch again, and backs off a few millimeters
  • Verify the X axis is now homed

From what you’ve described earlier, homing will not work after you’ve done all that, in which case I have no idea what’s going on.

If the X axis now homes properly, go through the same process with the Y axis and see if good fortune happens twice.

I appreciate this input!

I believe I have verified the first test through a different method:

  • My homing switches are not currently bolted to the machine
  • With the machine on and steppers connected (no homing in process), I tested the limits by putting them against the metal frame of the machine by hand
  • They lit up, and the diagnostic screen showed them turning on

Does this satisfy the first part of your test, or would unplugging the steppers possibly give a different result?

At this point, I’m just trying to verify that they can stop the machine during homing (by manually “closing” the switches), which I have not seen yet.

If you agree, then I’ll move on to your second test.

When a machine homes, it moves toward the sensor, when it locates the sensor, it will back off and re-engage the sensor at a slower speed.

These controllers expect an initial hit for finding it, then another hit to finish the operation.

If you’re activating the switch only once, then homing will fail … it needs to be done twice for each axes.


Right - I’m just saying I haven’t seen the gantry back off when I move the switches into position (lighting up when I move them against the frame) during homing.

I’ll go through the steps @ednisley stated above and report back!

Got it… just wanted to make sure…


You’ve verified that a piece of metal trips the switch, which is a good start.

The next step is to verify the switch works in situ, without having the machine smash into the wall when it doesn’t.

Disabling homing means the controller won’t be unhappy, unplugging the stepper motor lets you move the laser head slowly by hand, and having the switch in its proper position lets you verify it responds to the moving hardware as it should.

I’m trying to verify the switches work, so bear with me …

He stated that he could see the operation of the switches via the controller… I assume the Z/U → Diagnoses.


Ah okay - I see where you’re coming from. Thanks for clarifying!

Yes, via the screen on the laser - Z/U > Diagnoses

Okay, I did the first test. The limit switch worked - lit up and showed connection on diagnostic screen.

For the second test - I turned on home enable only for X-axis and somehow, it moved both axes during homing operation. I used the homing button via Lightburn.

I double checked settings just to verify I turned off y-axis homing enable, and it was off. Next, I turned off the machine, and unplugged the y-axis driver.

I held the x homing sensor in the path of the head - it lit up, but didn’t pause, stop, or retract for a second pass.

Poking the RESET button on the controller, which is what I detailed, keeps LightBurn out of this low-level testing. LightBurn requires the controller to be working correctly, which is not the case here.

We have a failure to communicate.

I’m willing to help, but you gotta hold up your end of the bargain by doing what I suggest and reporting back what happens. When you do something different, I can’t help.

I just clicked reset on the control pad - no homing or axis movement occurred.
I bolted the x-axis limit in place on the gantry as you have described - it lights up when the laser head is moved over manually.