Ruida controller upgrade

I am in the process of upgrading my Hans Leuming laser CMA 1080 -KT. I have replaced the RUIDA 6442G with a 6445S. Problem is it doenst seem to like the reed limit switches. If I wire in a mechanical one it seems ok But if I use the magnetic ones the controller locks up and power cycles. It also doesint want to focus the z axis. It doesnt seem to see the switches there.1 optical and 1 mechanical. It will engrave and cut with no homing so I can still use it Any advice would be appreciated.

Check if the magnetic switches are NO or NC and the same as the mechanical you tested.

Both NC. Its disturbing that it essentially locks up and faults the controller.Indicates to me a compatibility issue?. I would expect that if the switch was misconfigured that the machine would just fail to stop and grind.

How are they wired? Here is a schematic I found. I haven’t installed my 6445 yet.

These are normally open (NO) and generally run off 24V… The operational voltage range is 10V - 30V. They won’t operate off a 5V supply.

PL – long type (case)
05 – sense distance in mm
N – open collector NPN drive transistor

These are hall effect, not reed switches and change states when they come close to Ferris metal objects.

Here is a quick boot video watching the Ruida limit (home) inputs…

I run LPWM1 to the IN terminal of the lps… I like to keep it totally digital… really doesn’t matter for this, but you’ll see it more often than using the analog output.

Good luck


Yes they are wired like this. The mechanical switch I just put across the limit and ground terminals. Worked fine

Thanks for that.

Likely it won’t operate with the @micrololin supplied wiring for the home switches. Wonder where he got it.

I assume those are PL-05N hall effect sensors… can’t read them in the photo he supplied…


Cloudray amazon for the 6445. Also on cloudray itself.

Interesting, as you can see from my photo of my sensor, it’s only operable with a 10 to 30V supply…

They have it connected to 5V…?

Thanks for the link… isn’t the first time I’ve seen an issue with these companies.


Not just that: they’re connected to the Puxy terminal, which seems like it should have an internal “pull up” resistor to +5 V.

Measuring the resistor value (if any) would be an interesting exercise.

Great catch :hook: …


This is how they are wired on my KT332N. Probably the same as rudia. The power is on a different connector.

These have a different look with different options… He’s using CN4


Correct. The 3445 can operate an extra axis so CN3 was added. He could grab the 24v off CN2 like on my KT332N if Puxy is only 5v.


This is incorrect all home switches use the - inputs.

The + inputs… are limit switch inputs.

I wouldn’t use the 5V, it’s addressed in one of the manuals as a pull up.

The PL-05N specifies a 10 to 30V supply input, so 5V isn’t going to make it.


I colored the wrong ones. I’ll delete it. My original picture they are connected to the -

1 Like

So this is a picture of my type of switch.

So you have given me something to think about here. When I get back home in 2 weeks I will check what the voltage is on the old controller.

So those are not the usual inductive sensors we’ve been assuming the machine has. It (almost certainly) expects a supply voltage around +5 V and requires a magnet on the moving hardware.

If it’s from the SS39/49/59 Hall effect sensor series, then the output is a linear analog measurement of the magnetic field, which will not work reliably with the controller’s digital input.

What’s the part number?