Ruida laser etches fine but gantry stops at the start of shape when cutting lines

Just switched my red chinese Ruida controlled laser from a macbook to my windows machine connected via usb. Installed the drivers alongside the most current Lightburn. Laser connects and the laser is recognized fine. Laser etches perfectly fine. When cutting line shapes, either imported DXF or shapes generated within Lightburn, the gantry moves to the start position of the shape, fires but then doesn’t move. This laser cutter has worked fine for years on the macbook (which sadly died) so I am working under the assumption that something isn’t configured properly with the Windows 10 set up.

More likely that you didn’t configure Lightburn properly.

Did you ‘preview’ this at a slow motion to see what it’s supposed to do?

Does the Ruida controller show any kind of error message on it’s console.?

Might want to post the .lbrn2 file for us to examine, if that’s not a problem.

Good luck


Thanks, I don’t know if the lightburn file will make a difference, it is literally a single circle generated in lightburn. It will preview (frame) the shape correctly and etch the shape correctly. When I hit the start button to goes to the correct starting position of the circle and fires but just sits there. No error message on the laser’s display, but it does show the shape being cut/ cursor movement and makes a line on the LCD display

DOH. Lightburn speed is default configured for mm/s and I had my old mac set up for inches. It WAS moving, just very, very slowly. Switched the new setup for inches and I am back in business. Thanks!

Glad you figured it out.

Mark it solved

Take care


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.