Ruida Laser won’t allow higher than 400mm/s

Hi! I’m using a FL-690 80W laser. Any settings less than 400mm/s work great. But anything above 400mm/s on Lightburn doesn’t make the laser go faster. Somebody had suggested that the Ruida brain can’t go faster than that, even though my laser is capable of 1000mm/s. Is this true? Is there a way to override the Ruida brain so it just listens to the Lightburn settings?
Thank you!

Have you checked the machine settings?

I have to the best of my knowledge. It’s possible that I’m missing a setting somewhere. However, I set the speed to 500mm/s on the machine, and it stays like that until the machine runs, when it goes to 400mm/s. I have attached a picture as an example of the screen on my machine. Is there a setting I’m missing on the machine that you know of?

Well, maybe about a 100 or so. :slight_smile: There are many more settings to the controller that can be accessed directly on the machine through the control panel or through LightBurn via Edit : Machine Settings

If you do go into these settings, please be sure you back up the settings before you make any modifications.

And these are the settings you are probably most interested in adjusting. Once you change the numbers to your liking, you need to click “write” to save them on the controller:

Didn’t see you say it, but with Ruida you MUST read the current settings before you can change them and write them back to the controller. Simply changing and writing doesn’t do anything.

You’re too used to RDWorks. LightBurn reads the settings when you open the window, and it’ll simply not present anything to change if that fails.


1 Like

Good to know. It always seemed like a PITA to have to ‘re-read’ what was already on the screen read from the controller.

Thank you! I misunderstood your question, thinking you meant the settings that I can access on the machine itself. This is helpful, I will check this out! Thanks again!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.