Ruida RDC6442G-B dead?

I had a bad connection between the machine and the outlet which shut the machine off a few times during a cut. The controller powers up normally and connects to my PC. Once i send the file to the controller vis PC-USB the controller locks up and doesn’t display the file on the controller. I have to physically reset the controller to establish another connection, resulting in the same effect. Before i send the file i am able to move the head around, and frame out the job, however once the file is sent it locks up. Ive also tried to send the file via USB (uDisk) and it shows no file being on the drive when I’ve confirmed that it is. Am i dealing with a dead unit or do i have another issue here?

Do you know what firmware your controller uses? My 6445G uses V15.01.XX. I have .15, .19, and the new .22 on my Google Mod Page at the top if that will help.

This is what I have…


I am wondering if its a bad power supply? I would think that if the controller is working and allowing me to move the head and send a pulse that it should be ok…? Its just odd that after i send the file the whole controller locks up and has to be reset.

Hi, Dave01
In FW version .22 auto focus is working?
In my FW only in .15 working, .16 and .18(.19) not!

LP, Chris

Dave the firmware you suggested is for 6445, i have the 6442…

Rob, you know, these old eyes sometimes mix things up. sorry for that.

Chris. I have no knowledge of an auto ficus problem in any version, I don’t have it. The .22 for the 6445 is the latest, and that copy is direct from Ruida, not any of the suppliers. I’m doing some work with the new RDWorks beta and needed to update to the latest FW.

Its all good Dave…If anyone has the RDC-V8.00.57 firmware file ill try and reinstall it

Do a web search on the file name. You may get a vendor version with their logo on the screen, but it would be worth it to know the situation with a fresh FW load. I drop an email to my Ruida contact and see if I can do any good that way.

Problem solved! There was an issue with Lightburn’s newest update which wouldn’t allow me to send to the unit. I downgraded the software and all is good. Thanks for all your help guys!

Hi, can you also ask your contact about “focus” key on controler not working, or how to set up in new versions (I try .22 - Auto focus also not working)


You might go through the default options. I know when I went from .15 to .19 a few of the defaults changed and I had to go back in and reset them. Part of the .22 update was splitting off the rotary from the Z and shifting it to the U if rotary was enabled. They may have tweaked the auto focus a bit as well.

Good news, I got a replay back from my Ruida guy. The latest firmware files for the 6442 firmware is a .67. The G and the S are different files, so be careful. The release notes are in with the files on my Google Mod Page.

Dave, did we ever figure out what the difference between the 6442 G and the S models was? Some time ago I though the S was the dual tube model, but later learned that both do that stuff the same, so I don’t know.

S supports dual head, G is single. I made sure to put that in the release notes for future reference.

OK, I’ll try it Dave!
Maybe someone knows how to set the focus function in newer firmwares?
In .15 version focus is set as default!
I have G version and have support for dual head (one I using for laser bam and second for controling pen up/down - as a ploter) - dual head works in versions .15 .16 .17 .18 .19!

LP, Chris

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.