Ruida rescue file 50w Omtech needed

So I was tracking down an issue and decided to reset to factory defaults, to which I learned goes back to Ruida defaults and not Omtech. I found my (mechanical) issue and now need the default settings Omtech installs on these. I would greatly appreciate it if someone could supply me with it since I don’t know when Omtech will get back to me. I messed with rebuilding the settings and got things close but don’t have the time to keep messing with it like this.

Thanks in advance.

It requires that we know reasonably exactly what a machine you have, “50 Watt Omtech” is not enough.
@jkwilborn has a “50 watts omt”, I mean, but whether it “fits” to your machine …, he probably wants to help you. I have a 60 watt omt, 600x400 but with a ruida “clone” …

But if you would like my setup as a starting point to manually set your machine, then you can of course get it from me.

You can reload the most recent machine settings from LightBurn’s auto-saved config files. With a bit of luck, that will restore the controller to just before the whoopsie.

Go to Edit → Machine Settings, hit Load from Backup, and pick one with a suitable date. There’s no harm in working backwards from the most recent until you find the right one, although that might generate more backups, so keep track of the dates & times.

Happy hunting … :grin:

Nice suggestion, strange I didn’t think of that.
The whoopsie - I love that :rofl:

If a machine is working, there is about a 99% chance the failure will be the mechanical. We know mechanical things fail and at a much higher rate compared to electronics.

Everybody seems to go fiddle with the software on a previously working machine… the logic here has always eluded me.

I’ve developed my procedure that is, if there isn’t a good reason to reload software or firmware, don’t do it. Frustration with an issue will lead you down a very polluted path.

I don’t know when my last version of vendor settings I have, but I’m sure the acceleration values are probably outside the numbers needed to fix his.

I’d suggest you drop a note to OMTech and ask them for it. You can probably get away with a similar machine settings, at least to get you going.

Cardinal rule: If you’re going to change something, make a backup first.

It would have been much easier to ask here… :crazy_face:

By now, I’m sure your hindsight is 20/20

Windows… How do you fix it, reset to stock or a three finger boot :face_with_spiral_eyes: Every time you reboot it, things change… many are in this mode…

Good luck


Yes, I meant to include the link of the machine and have edited my post with it.

I tried this and unfortunately there was no backup

I reached out to Omtech and spoke to a call center that said it could take up to 72 hours for a response.

I am not well versed in lasers (if I didn’t already prove that) and while I did muck it up it has forced me to learn more about how the machines operate.

If you’d spent 10 times the amount you paid for a US or EU machine, you’d probably have it fixed by now…

We call that sweat equity… learn stuff you really didn’t want to know.

Hang in there…

Did you look into some of the areas you normally don’t see?

I am clueless about what os you run on your machine. I run Ubuntu and there are some system file, so to speak, that Lightburn stores, usually in places that are hidden. Most people don’t care about these so on Linux, they are in sub directories.

This is from the command line, if you use a version of Linux

jack@Kilo:~$ find ~/ -iregex ".*\.lbset$" -exec ls -l {} \;
-rw-rw-r-- 1 jack jack 12953 Sep 26 07:09 /home/jack/.config/LightBurn/backup/machine_settings/cyNS05MmQ4/20230926_070909.lbset
-rw-rw-r-- 1 jack jack 12953 Sep 26 07:13 /home/jack/.config/LightBurn/backup/machine_settings/cyNS05MmQ4/20230926_071305.lbset
-rw-rw-r-- 1 jack jack 6032 Oct 11  2022 /home/jack/mnt/dev-test/cnc/laser/machine-settings/grblHAL-default.lbset
-rw-rw-r-- 1 jack jack 12958 Mar 19  2022 /home/jack/mnt/dev-test/cnc/laser/machine-settings/220319-no-rotory-uped-speed-accel-1.lbset
-rw-rw-r-- 1 jack jack 12968 Jul 24  2021 /home/jack/mnt/dev-test/cnc/laser/RuidaviaEthernet_20210724.lbset
-rw-rw-r-- 1 jack jack 6037 Oct 11  2022 /home/jack/mnt/dev-test/cnc/laser/jl1/f/LightBurn-MachineSettings-JL1.lbset
-rw-rw-r-- 1 jack jack 6033 Oct  7  2022 /home/jack/mnt/dev-test/cnc/laser/jl1/LightBurn-MachineSettings-JL2.lbset
-rw-rw-r-- 1 jack jack 12967 Jun 20  2021 /home/jack/mnt/dev-test/cnc/laser/blue-laser-machine-settings.lbset
-rw-rw-r-- 1 jack jack 5556 Jan 16  2021 /home/jack/mnt/dev-test/cnc/bibo/engraver/temp/machine-settings.lbset

The first two are hidden from the general view, they start with a ‘.’ The rest are from me saving a specific configuration.

Might search your drive(s) for anything with a .lbset extension.

This is the oldest lb settings file I have. Some of the acceleration values may be high for you on both the X and Y axes, but it’s the best I have… sorry…

blue-laser-machine-settings.lbset (12.7 KB)

Mine is an OMTech China Blue, the basic standard 50W (ha ha) machine… here is a before and later photo… I’m sure you’ve seen a million of’em.

Good luck


That is one of the first things I did, unfortunately the only backup is just after I reset the unit for whatever reason.

The laptop I’m using is fresh with only Lightburn and RDworks, Cura, and F360 but I have yet to move any files over, so there isn’t many places I could miss.

My machine, save for the color, looks exactly the same. Built in 2018. As soon as I’m back in the shop I will give the backup file a try. Normally I have no issue prodding around until it works but currently, while it is close, has an issue that it will stutter on a test cut and then slam into the front of the unit, knocking the laser head almost completely off so I’m hesitant to keep tinkering like I usually would.

I greatly appreciate it. Omtech did get back to me and gave me the password to reset the unit, so I’m thinking it’s going to take them a bit to figure out my request.

I was under the impression that a factory reset required the Ruida password.

If they have you reset it before giving you the vendor settings you’d end up with a non working machine until the settings arrived…?

Doesn’t sound like a very logical process to me.

Can’t give you any kind of guarantee that my settings will work, but you’ve got nothing to lose… I’d still make a backup of the current one, don’t want to end up in worse shape.

Might want to lower the X and Y axes acceleration values… pretty sure those are from my time removing head mass.

When the Ruida is homing or some other function, you can usually press the esc key to abort the operation. That way you can keep it powered up while you debug the issue.

Don’t remember the build date but it’s at least 2020 I think… I know mine was the first that had an access panel on the left side where m2 live… Really am grateful for it…

I’ve never found the password or key to mine… all the lists I’ve seen, just didn’t seem to work. Do you mind posting it… then we’ll have a number of them to try :face_with_spiral_eyes:


RD8888 and CC8888 were the passwords to reset the machine. I’m pretty sure the call center in India did not convey my actual request so between 3 versions of English I’m betting it will take a while.

I don’t have a left side access port unfortunately but I’m willing to bet your settings will be much more accurate than what I have. I did make sure to make a backup before I started moving things around for exactly the reasons you said. I’ll report back when I’m in the shop

So Mr. Wilborn, your recovery filed worked. Machine is behaving safely now, except the laser won’t fire unless I use the “pulse” button, but I’m a hell of a lot closer than I was. I’m sure it’s something simple. Probably a lightburn setting since it operates just fine is Rdworks, I’m just even kess capable of using Rdworks than Lightburn. What should I check next?

Did you lower the acceleration values?

If you’re using the pulse button on the machines console, that means it’s working from there out.

I can’t think of anything to check in Lightburn. Only if your power settings are ok for the layer.

I’ll have to think about this…


I did not lower any values, it seems to be working exactly as it was before. I even reinstalled the laser into Lightburn at it’s behaving the same. Values between RDworks and Lightburn are the same, at least from what I can tell. I ran a test cut on some 1/8 plywood and RDworks cut easily at 5mms@40% power but nothing happens in Lightburn. It runs like it should, frame, home, everything but it just doesn’t cut, runs like it is cutting but definitely no laser activation.

I’m trying to see something common to point me anywhere.

If it will pulse, the controller would appear to be working.

Lightburn sends the control codes but I can’t imagine it not generating power…

Do you mind posting a screenshot of your settings and layer window so we can look for something?


I poked around and realized the minimum power setting was set to 2%. As soon as I changed it to 40% it started cutting, beautifully I might add. Thanks again for all your help

I have a copy of mine from April 29, 2023 if you can use something a little newer. It’s pretty much factory stock. I had a MF1220-50 with an RCD6442G controller.

I’m hesitant to change anything since it’s working so well but I am curious to see what the differences are, if you feel like posting it, thanks

Glad it’s functional…

Have fun…