Ruida went haywire? Engraving b t

Hello! You guys have helped me tremendously over the years just learning this machine, and lasering in general, i am hoping you guys can figure this out for me too!!
A few weeks ago i tried engraving a ss tumber which winded up engraving severely skewed. I read, watched lots of videos, tried everything, and nothing worked. So i moved onto a flat piece. This has not been working either. The machine is engraving all the transversal moves, and not the object i want engraved (sort of like its engraving the negative, but offset). I use LB but tried rdworks to see if its a software problem and its doing it there too. I wrote the factory settings back to the controller and its still doing it.i will also mention when i was messing with the tumblers it appeared that the machine was sporatically firing. Now its firing all the time, just not where its supposed to. Also when i hit frame at the machine it fires, which is where the box on the glass came from, but framing using the software works fine. Up until i tried the tumbler last month everything worked fine. Also the last attempt i made caused the machine to start engraving front to back instead of left to right with no changes to initiate that. I have a ruida controller. 50w blue chinese laser. The preview is correct. Could all these problems be caused by the power supply?

The Ruida controls the lps vis only two control signals. One is the IN terminal for setting power level, the other the laser on signal that tells it when to fire.

It sounds like the lps has gone south…

On most of these you can just unplug the control signal connectors at the Ruida or the controller, run it and see it it still does that. Without the control signals, it should not fire unless you press the test button on the lps.

Connector on the left, is the mains supply, on the right is the control signals.

If it still lases with the control signal connector removed, it’s the lps.

It looks like the machine is being controlled properly… i.e. it appears to follow the right path. I’d suspect the lps.


Hi! Thank you for this info. I unplugged the connector that appears to be the control signal, and it did not fire. I plugged it back in and its still doing the same thing. So I should just buy an lps at this point then you think right? Thanks again for the help!

Let me add here…i just ran a file in line only mode, and it did the sporratic firing (the lines u see in the photo). So, none of the functions are working right; line causes these lines and fill engraves the opposite of what it should.

If you unplug the controller and it doesn’t fire, then it points to a problem with the controller.

Do you have a voltmeter so we have you check a couple of the signals?


Oh… i disconnected the control signal from the power supply, assuming that would be the same result. Im not sure which is the controller. Yes, i do know how to use a multimeter. What do u think i should check? (Thank you for all the time to help!!)

The Ruida controls the lps via a common ground and the signals of L-On1 and either L-AN1 or L-PWM1. One is analog dc control voltage and the other is digital pwm. The IN input of the lps works with either analog or digital input.

This is the most common way they are wired. In the photo the red labels are the lps input labeled IN and L.

The L-On1 is laser enable and tells the laser to fire when it goes low.
LPWM1 will reflect a voltage relative to the % power in the 0 to 5V range (TTL).

The LPWM1 output will read about 2.5V at 50% power.
Check the L-On1 line to see if it’s ‘stuck’ low. It should be high if you are not running a job.

If anything is an issue, it’s probably L-On1 as the pwm runs the whole time the layer is executing. That would fit the symptoms.

You can just draw a line and run it with the lps mains power removed. You don’t need to have the lps running to do this. Usually they have a separate switch.

Make sense?


Thanks, Jack. Im going to try wrapping my head around this info, tomorrow hopefully. Its been a long day today and im ready for bed lol. I will let you know what comes of it as soon as i know. :slight_smile: Thank you again!

Well Jack, i have some great news. Its all fixed now-after i spent hours reading, checking wires, taking everything apart, etc.-i found the issue. So when i was going through machine settings when the tumbler issue came up, i changed the laser to high power in the vendor settings, because i thought i read somewhere my unit was set to fire hire power. I did re-write the settings to factory earlier in my steps like i said before poating here, but apparently vendor settings do not get changed. So once i manually went in and changed it back to low, everything is back to normal!!! Yay!!! This is why i shouldnt mess with vendor settings lol!!! Thanks so much for the help!!! It was a great learning experience!!

What exactly did you change?

It would be nice to know.

You should always save your basic factor settings before you modify anything. It’s too easy to miss something…

Glad you’re back up and it’s not a hardware issue…

Good luck


I changed the “laser 1” power to high (it was on low), in the vender settings.

Yes i did back up the settings but the vendor settings apparently are not included in that. This is the first time i changed anything in that section, so i was never worried about it. But it might be good for someone else to know if they do change the vendor settings, they need to document it somehow because it doesnt transfer. At least it didnt for me.

Thanks again!!!

The save to file option backs up everything, the vendor settings specifically.

Have fun…


Ok. Idk why it didnt in my case. I have a folder with them all. But ill be checking from now on lol. Thanks!!