Ruida Z-axis/limit correct behaviour?

Hi! I’ve inherited a BRM90130 at work with a Ruida 644x controller. However, it behaves a bit strange and I’m not sure the z-limit switches is connected correctly. Or something is off in the config.
It got a autofocus-probe which acts as one limit switch, and a second one at the lowest table setting.

  1. Should the autofocus probe be connected as Z- or Z+?

  2. When I hit Focus, the table moves away from the nozzle towards the bottom, hence increasing the Z-distance. I guess it should move towards the probe? Any suggestion to which setting to change?

  3. Can I enable a setting to make sure a user cant crash the table into the nozzle? I.e let the focus probe act as a limit switch all the time?maybe that is a defauly behaviour?

Thanks in advance!

Z- is typical, since the laser head is “moving down” as the platform moves up.

Edit > Machine Settings > Vendor Settings > Z Axis Settings > Direction Polarity (toggle)

Acting as a limit switch the whole time is the default behaviour as far as I am aware, as long as this setting is enabled: Edit > Machine Settings > Vendor Settings > Z Axis Settings > Limit Trigger

Note: Proximity to the laser nozzle area will expose the probe mechanism to a lot of smoke, tar, grime, and sticky dust. The probe will have difficulty with thin/soft materials, and due to it’s very close proximity to the work will be prone to lateral collisions.

1 Like

Thanks for your very clear answers, appriciate it!
I will test it back at work next week!
And yes, I forced them to buy a couple of licenses from you, awesome software!

Looks like I need your(or anyones) expertise once more.
I was by my workplace quickly today to teat your settings.

However, i could only manage to jog the z-axis upwards towards the nozzle. I do remember that I could jog it both up and down before vacation time.

The autofocus probe was indeed connected as Z-.
No switches was highlighted under Diagnostics menu.

1.I tried to reset the controller, and it homes X/Y but not Z. Z-distance was set to 3000mm after reset.
“Enable homing” was green under Vendor settings.

2.I tried to switch Direction Polarity, but the bed still only goes up. It did however switch the buttons on the controller that controlls Z-movement.

  1. Tried to toggle “Limit Trigger”. No change in behaviour

Not sure if this is normal behaviour? Not so familiar with the Ruida controller.
Or could it be a faulty Z+ sensor(the one in the bottom of the table)? Even though it is not “red” under Diagnostic menu?

This has to be enabled within the Ruida… Each axes can be enabled or disabled for a home operation. Did you enable the Z axes home?

It it’s not enabled, I would expect the Ruida to ignore it.

If you did this on a working machine, it should fail.

Do you get any error messages on the Ruida console?


Thanks for you reply!
The ”Enable homing” is indeed enabled for z-axis.

I think something is off as I cant manually move my Z-axis in both directions. Only up towards the laser nozzle.
However the z-axis measure/coordinate do change on the controller display when I try to move down, but the stepper motor is not engaged.

No warning messages on the display either unfortunatly.

Take a few and watch one or more of the Russ Sadler videos… He has a number of them on how the Z axes work and may benefit you in solving this…


That is the symptom of the stepper driver either not getting the signal telling it which way to move or simply ignoring the signal.

Check to see that the Z-axis DIR signal is functional at the controller and at the stepper driver; the wire connecting the two terminals may be broken for reasons nobody can explain.

A voltmeter should show the signal at around 0 V while you jog the Z axis in one direction and about 5 V in the other direction, as measured with respect to the controller’s GND terminal.

If the DIR signal is changing at the stepper driver, then the driver is most likely damaged and will need replacing.

Thanks! That will be my mission back at work next week then!

Thanks everyone! The issue is a glitchy Z-axis contact on the ruida controller. Most likely the contact on the controller, rather the connector on the cable.
But it is worth to try change the cable connector first I believe.

Do anyone know the name of the connector?

Somebody finally traced the problem down to a completely missing contact inside the cable connector: no guts!

May yours be as simple to fix …

As the saying goes, “Phoenix. Phoenix Connector”:

CAUTION They come in both hard metric (5 mm) and quasi-inch (5.08 mm) spacing that matter in blocks of two or more, plus 3.5 mm (and likely other) variations. Trust, but verify!

I got these from Amazon, and they work fine with the Ruida and also the motor drivers…

Motor drivers are usually 6pin, but sometimes are 4pin + 2pin, whereas the Ruida is usually built with 6pin or 4pin + 2pin connectors…

Good luck


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.