Runs into limits

I am new to this software but it looks good and easy to use.
However I am having problems.
I have an Eleksmaker. It has hooked up well and I have a small square I have drawn on the screen. When I ask it to FRAME the laser moves off to the bottom LH corner and crashes into it. I realise there is no limit switches on the axis. But I cannot seem to stop this ‘homing’ action. What setting di I need?

Do you have ‘Homing’ set in your firmware? If you have that turned on and don’t have limit switches, this would cause what you are seeing.

Which ‘Start From’ setting are you using?


Many thanks Rick and Oz. That problem is now solved. V good info.
Now I can control it but although I have a laser dot it will not engrave or mark! It is on all the time. I have upped the power to 97% and reduced the speed to 100mm/min but no marks on the card.When I hit RUN I was expecting the laser to go brighter but it stays the same. What could be preventing the laser from going to a higher level? It has marked and cut paper with the Eleksmaker SW but their SW is so prone to crashing just keeping it going was just too much. But at least I know the laser works ok.

You do not have your settings set correctly for laser use in your firmware. You will need to do that first to get LightBurn to work as you’d expect.

Typically we have seen this machine ships with an older version of grbl so go with the GRBL-M3 (1.1e or earlier) device in LightBurn. Ideally, you would upgrade the firmware to GRBL 1.1f and then use just the GRBL device. There is a separate group for these types of machines on Facebook and quite a few people there use LightBurn, so they sould be able to advise you more.

Check your setting for $30 and $32 in the console by typing $$ and pressing enter.

$32 should be 1 (enable laser mode)

$30 should be 1000

The $30 value can be set either in your firmware to match LightBurn, or in the LightBurn device settings (S Max) to match your GRBL setting.

Here is another great resource for your setup.

As another member previously posted, “Scroll down to the bottom “operating instructions” and follow that. Once you have it working in elekscam, it should work in lightburn. Follow the instructions to the letter and that will get you up and running…”

1 Like

Have had a look at all the $ settings as you suggest but it only lists them from $0 thru to $27 and from $100 thru to $132 but with some gaps. $30 and $32 simply not listed at all.
So $30 which I realise I can set from the S value and is now set to 1000. Tried typeing in $32=1 in console but get an error message.

Since writing the above I have this morning now tried a run and hey presto it burns. So what has happened? Did it register $32=1 even though it said error? However now after a running, the laser will not turn off!! So I have reduced power to zero. Surely there must be a way of turning the laser power on and off from LightBurn dirrectly?

If you’re using a version of GRBL older than 1.1f (you are) the commands and settings are different, and the GRBL-M3 driver accounts for this. There’s no laser mode to enable, and the spindle “rpm” value (S value) is fixed at 255.

Are you using the GRBL-M3 Device profile in LightBurn? As Oz mentions, there is no laser control in these earlier version of grbl. The spindle “rpm” value (S value) is fixed at 255. The EleksMaker document I shared is an excellent reference to getting your laser to work with LightBurn when using their “pre-laser support” grbl version.


Upgrading the firmware is also covered in the EleksMaker link I provided above.

Hi Rick
Yes the firmware is listed on the LightBurn Laser menu as being GRBL-M3(1.1e or earlier)
I will try updating this as you suggest but will not be able to do this until late on Monday now.
Thanks for the help so far.

Hi Rick
I have updated the software to GRBL 1.1f. I did this after downloadng GBRL 1.1f by useing T2Laser software which allows you to select which GBRL version you wish to use and then transfers it into the Eleksmaker hardware. I checked that it all worked with T2Laser first and it did all work perfectly from what I could see. Made engravings, turned laser on and off and also it was able to engrave at different power levels. Then I went back to LightBurn. It still gave the same issues. I tried to get LightBurn to switch to GRBL1.1f but the menu section bar in the Laser panel will only list GRBL 1.1e and all the same issues are still there. So other software is quite happy to control the laser but LightBurn seems to have problems with power levels etc. Have I done something wrong within LightBurn?

With GRBL 1.1f or later, please re-read the post I provided earlier (linked below). These instructions have help the many EleksMaker owners currently using LightBurn get things configured correctly.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.