S.O.S. New kid in this block and am stuck badly

Everyone,

I am so excited to be a part of this community now :slight_smile:

Very quick background: I have had my XCarve for the last couple of years and am very comfortable with using the CNC and software VCarve, Picsender, and Easel. I recently purchased a small Ortur laser device and a Lightburn license with it. I am pretty comfortable with using the software and the small machine too. Last week, I decided to upgrade and purchased a 7-watt JTech laser kit, receive it yesterday, followed all instructions, and installed in on my XCarve. I am on Grbl 1.1H version on my machine.

Issue:
First, Lightburn detected my machine and successfully installed it BUT I have no luck getting the origins and movements to work. To give you an example, I can successfully home the machine to the bottom left of the board with Lightburn but any mother movements would go haywire and hit the sides and completely wrong (i.e. G0 X2 Y2). I read an article/posting about setting the negative offset to resolve the issue but am wondering why others who used the same software on the same type of machine did not have to do anything like this? What am I doing wrong? Any suggestions? I am so anxious to get my machine up and running and would appreciate your help and suggestions.

Thanks,
Allen

“Completely wrong” doesn’t give us much to go on. Does it go in the wrong direction, too far, is both axis affected?

My guess in the dark is you have the origin set incorrectly in lightburn, Maybe you have it set to the top right?

1 Like

I am not sure what you are asking, but I can share a link to our documentation for setting up, using an XCarve based motion control system. Common Grbl Setups - LightBurn Software Documentation (#shapeoko-xcarve-and-other-negative-workspace-systems)

Have you had a chance to review this before? Is there something specifically not working when using this document to complete your configuration? Looking for a bit more clarity and details.

Tyler,
Thank you for your quick response. I was not sure how much details I could provide in here but by “completely wrong” I meant that, being at home (X0 Y0), when I run "G0 X2 Y2), the laser (the gantry) tries to move downward towards the bottom of the board and keeps hitting the home switches instead of going up and to the right . So, yes, it goes to the wrong directions. There was an article/posting about using an offset (working area sizes (-787mm by -787mm)) to get this corrected.

Here is the link to where the posting was at this location:

Thanks again for your help. Please let me know if you have any suggestions.

So your machine physically homes in the bottom left corner, but where have you told the software your machine homes. You can find this under Edit>Device Settings.

image

Rick,

Thank you for your response. This is exactly the posting that I was referring to. I have seen YouTube postings that claim that “there is no need to make any configuration changes in your CNC when you use Lightburn”. I saw folks just starting Lightburn and run their projects without any changes.

Well, I might have been wrong. I will try what you suggested.

Thanks again

I do have the origin set as it is in the picture but I think this is a known issue with different origins between CNC machines and Lightburn. You can read about it in the other responses to my question.

Here is another question though. Instead of manually modifying and setting the negative offset, could we use the “Laser Offset” by negative amount?

I hope that I make sense :slight_smile:

I am not following you. Known Issue? What issue? Did you try the things suggested in our documentation? How did that go? What result did you get?

If you are asking about this “Laser Offset”, no. If you hover over most things, you will see a tool tip bubble offering more information, and hit F1 for even more.

I have not seen this content, don’t know the context. I do know what we wrote in our documentation. :wink: I am not understanding, as this feel as if you are resistant to the instructions provided.

Everyone, Thank you all for your help. I will try the suggestions and will post the results in here.
Thanks again to you all

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.