S-value show in mm/min or mm/s according to language


I noticed that depending on the language used in LB, the speed is expressed in mm/min or mm/s (english mm/min french: mm/s) ?!

On the other hand, I understood that the S-Value parameter must be equal to $30 but how do I know this value? (I upgraded from 0.9i to 1.1f and $30 did not exist in 0.9i, so I don’t know what the factory value was.)

For the record, I timed my machine on a 250mm x 250mm square (so 1 m): it took 21 seconds (full speed). Which parameter should I put in S-Value and $30 to get an estimate of the real time? 1000/14=71.4 mm/sec

PS. Excellent software, I just bought my license today at the end of the trial period.


The $30 is for controlling “max spindle speed” in grbl, not the settings used to control the speed of your job. Enter $$ into the LightBurn console to see what the current firmware setting of your controller. The $30 value can be set either in your firmware to match LightBurn, or in the LightBurn device settings (S Max) to match your GRBL setting.

As for tuning the estimated time provided in the ‘Preview’ window, we have added adjustment settings in the ‘Additional Settings’ tab under the ‘Device settings’ window.

I am not seeing the same when I change the language to french using ver.9.02 on mac. These settings are controlled from the ‘Settings’ window. Could you have inadvertently changed these settings by mistake?


I’m not sure what this formula is representing here. The ‘1000’ value in the $30 setting is just the maximum value that GRBL expects to see, and will produce 100% output on the Spindle PWM pin. Older versions of GRBL only have 8 bit PWM, so they use 255 as the maximum. Newer GRBL defaults to 1000, so that’s LightBurn’s default as well.

If you use the “Find My Laser” tool in LightBurn to set up your machine, it queries the controller to find the correct value and sets it for you. As long as the number is at least 255 your should get good power control, and the two numbers have to match, but you would see no difference in speed of output between using 255, 1000, or 5000. It’s just a mostly meaningless number.

To get the simulation times more accurate, look at the machine settings for acceleration and max speed ($110, $111, $120, $121) and copy those numbers into the speed and acceleration settings Rick showed above. Rapid speed is the same as Max speed. Cut and engrave accelerations will use the same acceleration values.

I found out what’s going on: It’s the Cut Info window that’s not updated directly when you change languages. It always returns to show mm/s and only updates (mm/m) if you open parameters and click on OK
(In the parameters window I am of course on Diode)
(Or it’s my configuration that’s damaged?)

It’s not embarrassing, since it works, but it can be confusing.

Sorry for also confusing $30 (tool speed / laser pulse) and the speed of movement. I was a little tired from doing too many tests.

Here’s my $$
(LB 0.9.02 - EleksMaker A3 Pro - Mana SE v3.2 - GRBL 1.1f)

As the firmware update (0.9i to 1.1f) erased the factory settings, I would be interested to compare with the settings of other experienced users of this machine, if any.


That being said, everything is working well now.


Ahh - that will need to be overridden manually. The translation system resets all text, including the ones I overwrite in code. When the language is changed I’ll have to re-apply the changes to unit settings afterwards. Thank you - this makes more sense.