S30 ultra, homes correctly but it seems like coordinates are reverse

Installed limit switches. Homes and jogs correctly but i go to start anything from home position it tries to come forward and hits the rail and stopsHoming
ok
$$
$0=10
$1=25
$2=0
$3=4
$4=0
$5=1
$6=0
$10=1
$11=0.010
$12=0.002
$13=0
$20=0
$21=1
$22=1
$23=3
$24=200.000
$25=3000.000
$26=250.000
$27=2.000
$30=1000.000
$31=0.000
$32=1
$41=0.000
$40=0.000
$100=80.000
$101=80.000
$102=250.000
$103=100.000
$104=100.000
$105=100.000
$110=6000.000
$111=6000.000
$112=1000.000
$113=1000.000
$114=1000.000
$115=1000.000
$120=1000.000
$121=1000.000
$122=1000.000
$123=200.000
$124=200.000
$125=200.000
$130=375.000
$131=380.000
$132=200.000
$133=300.000
$134=300.000
$135=300.000
ok
Position laser x20 y31 and it hits the rail
Starting stream

Stream completed in 0:01

ALARM:1

Hard limit triggered. Machine position is likely lost due to sudden and immediate halt. Re-homing is highly recommended.

Grbl 1.1h [‘$’ for help]

[MSG:‘$H’|‘$X’ to unlock]

ok

ok

I compared your settings with my S30 Pro:

  1. Turn off $21, You need limit switches on both ends of the travel (4 switches total) to use this feature.
  2. My $23=7 does not match your $23=3. You can try changing this thru the Machine Settings window.

ok i will try do some wiring to get 4 switches going.
When i home it reads 0 0 . Move it up and right 10mm it reads x 420 and y 410

Jog it up to the top right corner it reads position as x 800, y 780. Its set for 370 and 365

Make sure $13=0 to report mm instead of inches.

$130 shows 375, $131 shows 380 in your $$ listing… Again, $13 may be the culprit.

Make sure EVERYTHING is in mm, including at the top of the workspace window.

Everything is reading in mm
I opened laser GRBL, got the same readings when i jogged it up and right 10mm each
Hit the home button then hit zero home and it zeroed everything. Opened LB and the settings zero there as well.
If i close it out and close laser GRBL i do have to re zero it again.
Not sure what i can do to keep the settings permanent but it is working as it should

Okay, it is working, but the position info is confusing, right?

In the Console window, enter $$, and then $#. Copy and paste the results from the Console window to a Reply here. I have the S30 Pro, so our settings should be very close.

As an afterthought, make sure the rotary is not enabled.

$0=10

$1=25

$2=0

$3=4

$4=0

$5=1

$6=0

$10=1

$11=0.010

$12=0.002

$13=0

$20=0

$21=0

$22=1

$23=7

$24=200.000

$25=3000.000

$26=250.000

$27=2.000

$30=1000.000

$31=0.000

$32=1

$41=0.000

$40=0.000

$100=80.000

$101=80.000

$102=250.000

$103=100.000

$104=100.000

$105=100.000

$110=6000.000

$111=6000.000

$112=1000.000

$113=1000.000

$114=1000.000

$115=1000.000

$120=1000.000

$121=1000.000

$122=1000.000

$123=200.000

$124=200.000

$125=200.000

$130=372.000

$131=380.000

$132=200.000

$133=300.000

$134=300.000

$135=300.000

ok

$#

[G54:-410.000,-400.000,0.000]

[G55:0.000,0.000,0.000]

[G56:0.000,0.000,0.000]

[G57:0.000,0.000,0.000]

[G58:0.000,0.000,0.000]

[G59:0.000,0.000,0.000]

[G28:0.000,0.000,0.000]

[G30:0.000,0.000,0.000]

[G92:0.000,0.000,0.000]

[TLO:0.000]

[PRB:0.000,0.000,0.000:0]

ok