S9 laser no longer firing after following the GRBL firmware update

Hi. I followed the instructions to fit limit switches detailed at Go Home! - Installing Limit Switches On A Diode Laser - YouTube. I’m happy to report that everything worked perfectly and I completed a couple of projects. Having gotten annoyed at having to remember to run the macro to set limits I followed exactly the steps in Installing Clean GRBL Firmware on Diode Lasers - YouTube. After this my laser homes and moves for the job but the laser doesn’t turn on.

I tried to go back to stock firmware using the Sculpfun instructions. Sadly my ancient pc (Mac household) refuses to talk to com6.

As an aside I’ve just bought an S30 to complement my S9 (which has been upgraded to 400x900). It’s not the cables I’ve checked. I connect up the S30 controller and the laser fires up just fine.

Any suggestions??

I would try to reinstall the firmware. There could have been a problem with the transfer.

Just tried that …. No luck. I’ve ordered a replacement controller board.

In the Console window in LightBurn, request these two reports by typing the following into the console window.
pressing enter after each one.

The first one $i (Dollar I), will usually give you the grbl commit date and Option Codes.

The Second one $$ will give you the Machine settings.

Please Copy and paste both of these into a report here.

It’s easy to mismatch the $30 vs. S-Value max and cause the symptom you’re describing.

I strongly advise to select the according firmware from this page: Firmware Update & Settings - Diode Laser Wiki These versions are tested and known to work with all Sculpfun laser types. The page also includes a table of standard settings that should be set. Just in case.

Target buffer size found

checked S-max $30 both at 1000

I followed the instructions using Arduino IDE and the Lightburn posted GRBL. Mac household here, ancient windoze 7 netbook won’t talk to COMXX.

The windows device may need the CH340 driver.
Do you have a link to the firmware?

It’s possible that the baud rate is set low to improve communications.

Linux to the rescue! I managed to flash Sculpfun’s provided hex file using a Raspberry pi (instructions here: Flashing Arduino hex file in Linux with Avrdude – Skjoldtech).

Sadly it hasn’t helped :frowning:

I must have fried something some how.

Did you try flashing my version? Afterward, send “$RST=*” via the console and all settings are reset to optimized defaults that definitely work with an S9.

Now I have a way to flash I’ll give it a go.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.