Sainsmart 3018 and OxLaser 2.5W burning in white space and won't shut off

I’m so new to this laser etching and burning with this new equipment.
I have a Sainsmart 3018 with a Woodpecker 3.2 control board running the latest GRBL 1.1h formware.
I purchased a cheap OxLaser 2.5 watt online and it came with two separate connector cables.
On the OxLaser there is a 3 pin connector with 12V+, GND and PWM.
I am currently using the 3 pin to 3 pin cable which is plugged in to the 3 pin Laser port on the board.
It also came with a 3 pin to 4 pin, (2 separate 2 pin molex connectors) not currently used as there is no port on the board to plug the 2 separate molex 2 pin connectors into.
My issue is that the laser has an off/on switch on top and in the off mode will not activate to burn anything.
In the on mode the laser is on all of the time and will not turn off through PWM when traversing from one burn area to another. It just leaves burned lines where ever it travels.
Boy, do I need help or what…
Thanks to anyone in advance who can sort this out for me.

Start with the basics:

  • Have you enabled laser mode? ($32=1)

Yes, I have enabled laser mode $32=1 however nothing changed.
The laser I have has a small, what I assume to be, a control board attached to the top of the unit with four screws.

I read where these lasers need a 1K resistor soldered between GND and PWM.
I completed this mod and still same result.

Then I read another document that advised with these lasers there was another mod that could be done so off to the soldering iron once again and soldered a 10K resistor between the PWM wire from the laser to the bottom pin of the MOSFET. Again this mod ended with the same result.

I am seriously considering taking a hammer to this laser and ordering a different one if I can’t get it to work properly. I have gone through a crazy amount of material with ruined designs as a result of this issue.

I can’r seem to find if the issue is related to hardware, firmware, software or G-code.
Too many parameters to try and test out to determine the underlying problem.

Any help to resolve this issue would be very welcome…

I don’t know this machine, unfortunately. If you have laser mode enabled, and have the $30 parameter and the S-Value Max device setting matched, there shouldn’t be any reason for the laser firing. If you’ve altered the hardware, anything could be wrong.

Hello. I have my laser from same chinese company, but the 15w version. I had the same problem when the PWM wire was not connected to arduino. Try to check if the PWM wire is connected, or with a multimeter if the 3 wire cable is broken.

Robert,

Thank you fir the reply.
My laser arrived with 2 separate cables, one has a 3 pin to 3 pin molex connector and the second one has a 3 pin to two 2 pin molex connectors. This one has the 2 grounds, (black and white) combined. I have tried using both but the same issue is the result but I will now check the yellow PWM wires for breaks in both cables. Thanks for the tip.

I am using 3pins to 3pins cable. The PWM wire (yellow) connected to arduino nano at pin D11.

Robert,

I have no idea where pin 11 is.
Would it be possible for you to send me a photo of your board indicating where pin D11 is located.

Thanks in advance.
JR

Thanks for the info.
I completed the 2 mods to the hardware separately however, since nothing changed I removed the mods and went back to OEM. Still having the same issue.
I have written to both Sainsmart and OxLasers for some assistance and/or to replace the Woodpecker board and the laser to see if that makes any difference.
I will post back if/when I am able to get this working with the fix details.

Can you post a picture of your board? Now i saw you have a Woodpecker 3.2 control board.

My cable is Yellow-black-red (PWM-ground-12V). From what i saw on internet, your board can have swapped PWM and ground wires.

My laser cable