Sculfun S9 and Makerbase DLC V2.1

I am currently having trouble setting up my Sculpfun S9 and Makerbase DLC V2.1.

Lightburn see the device on COM3 but any commands given doesn’t move the motors.

I’ve done the following:

  • Flashed the Makerbase DLC V2.1 with the latest Normal Laser Firmware
  • Connected the X motor to the X motor and Y motor to Y1 motor, connected to 12v output and connected the S cable to the S cable for the 3 pin option.

PS. I have a 12v powersupply.

Do not flash the MKS firmware. Flash original grbl, better the version I provide here (the S9 version):

and maybe also have a look here:

Hi Misken,

Thanks for your reply. I flashed it with the S10 Firmware both the BT version and non BT. Its detected in lightburn but the motor still do not move. Any Suggestions?

I’ve also the tried the S9 firmware but that wasn’t even detected in lightburn.

Oh, it was my fault. I didn’t check the picture close enough. You have the DLC32 board. Not the DLC. So, you can only flash 32 bit firmware, no the S9 firmware. In this case, I recommend flashing FluidNC and use the configuration files provided on the wiki. But I think the original laser version of the MKS firmware worked as well for me, at least the motors should turn then.

I’ve tried now FLUIDNC still no luck with moving. Do you have a guide on advanced troubleshooting? Or we can have a call on discord if you have the time.

Sure. Did you use the yaml from the wiki? Does the laser fan turn on?

  • The Laser Fan does turn on and the light on the board above the laser turn on to.
  • I’ve tried the YAML.

My Original problem is my original DLC V1.1 board that came with my Sculpfun all of a sudden stop controlling on of my motors but if i switch the X and Y cables the other motor works. Which ruled out the motors not working. I tried also different cables from Sculpfun which ruled out the cables.

I had came to the conclusion that its my board that is causing this which made me buy the Makerbase DLCV2.1 board in an intent to replace my V1.1 board.

Be aware, it is a (major) difference if you have a Makerbase “DLC 2.1” or “DLC32 2.1”. From the picture you sent, you have a DLC32 board.
Both motors do not turn? Or only one does not? To me, it seems more like a connection problem than a problem of the mainboard.

Hi Misken , I am quite new so I found my newbie mistake :slight_smile: . My orignal board had motor drivers built in but my new DLC 32 board did not which is why the motors didn’t run. I’ve now set it up just fine.

I am just wondering is there a possibility to use the wifi capability of my V2.1 DLC32 board and work from lightburn directly?

Yes and no. You can install FluidNC and use the web interface. But vor direct laser control, I highly recommend using the cable. It’s much more stable and you should ALWAYS stay close to the laser while it’s running. Some more comments on this topic: Laser Remote Control - Diode Laser Wiki

Hi I have exactly the same problem as you Bluef16 (makerbase dlc32 flashed, connected to lightburn but nothing move), i would like to know how did you solve the problem about the motor drivers ?
You talk about “set it up just fine” but i dont find how to do that.

Common mistake on new setups with GRBL is ignorance of settings and system readiness. Did terminal prompted you to type “$x”? Is hard homing enabled? As a safety GRBL will not move till properly homed or setup to not hard home.

I’m not sure. maybe. worth to try. This is a common head scratchier with new setups.

Hello, thanks for you replay LsrSal.
I bought A4988 Stepper Motor Driver Module on Amazon, they just arrived and this was the problem. I pluged them on the markerbase dlc32 and now motors move. I didnt do any settings yet, but at least they move :grinning:

What I find incredible is the lack of documentation. At no time on the internet did I see that I had to buy these modules. Luckily there was this forum. In addition, I seem to have seen people on the internet who operate the makerbase dlc32 without these modules.