Sculpfun S10 - waiting for connection / installed limit switches


I have a known problem with a limit switches. After connection limit switches to a main board a laser have a problem witch connection. I see an info: “waiting for connection”. After disconnection of switches laser laser works correctly again.
Have someone a solution for this issue?
How do You think, if firmware update of mainborad could be a solution?

You’re saying as soon as you connect the switches you can no longer connect to the controller? That’s very odd. Only thing I can think of is that this shorting out the controller somehow.

Try connecting one switch at a time and seeing if the controller will respond. Perhaps one of the switches is bad.

Can you take a photo of the switch and the wiring on both sides of the connector?

Hello berainlb,

yes, i will take a photo. I thing, that i have a problem with firmware with a homing bug. About limit switch: when i switch it manually, a diode is working correctly, co it suggest that wiring is okay, anyway I i will check it again and show results

Can you connect to the machine and run these commands in Console? Please copy/paste text output.


Just for the records: the original firmware of the S10 has a firmware bug, but this doesn’t affect overall functionality. So, this is not the reason in this case.
It’s most likely wiring. If the wiring is correct, check it without the switches mounted to the frame, I already had some users that created the short while mounting the switches, not in the cabling itself.

when limit switch is wired, a console is not working

Run in Console with switches disconnected.

Also, review the post from @misken. He’s very familiar with the Sculpfun models. The suggestion of checking switches unmounted from machine is sound. You could be shorting out during the mounting process.

i wired totally new limit switch:

If you test one switch at a time like that, are you still unable to connect to the controller?

Yes, it is still not working. After wiring 1 limit switch i see info “waiting for connection” again

Are the pins on the board marked? So it’s clear which is V, G, S?

If you activate the switch, are you able to connect?

Does the led light up on the switch if you press it?

I pushed a limit swith, then wired to motherboard. When i swithed off a limit swith i got an info:




[MSG:Using machine:XY DLC32]


A2 : 0x80138dd8 A3 : 0x3ffb8058 A4 : 0x00000001 A5 : 0x00000001

A6 Guru Meditation Error: Core 1 panic’ed (IllegalInstruction). Exception was unhandled.

Memory dump at 0x40089770: 81004136 20c0dbaf 80088800

Core 1 register dump:

PC : 0x40089774 PS : 0x00060033 A0 : 0x8008979f A1 : 0x3ffb1bb0

A2 : 0x00000020 A3 : 0x00000000 A4 : 0xeba91bbc A5 : 0x00000001

A6 : 0x00000000 A7 : 0x00060323 A8 : 0x0000007e A9 : 0x0000007c

A10 : 0x0000000a A11 : 0x3ffb1f50 A12 : 0x800d30f6 A13 : 0x3ffb1e00

A14 : 0x3ffc3758 A15 : 0x00000003 SAR : 0x0000000a EXCCAUSE: 0x00000000

EXCVADDR: 0x80138dd8 LBEG : 0x4000c2e0 LEND : 0x4000c2f6 LCOUNT : 0x00000000

ELF file SHA256: 0000000000000000

Backtrace: 0x40089774:0x3ffb1bb0 0x4008979c:0x3ffb1bd0 0x40089a5f:0x3ffb1bf0 0x40089ba9:0x3ffb1cc0 0x40089e91:0x3ffb1ce0 0x40087f2a:0x3ffb1d00 0x4008ca35:0x3ffb1dc0 0x400d88b5:0x3ffb1de0 0x400d70af:0x3ffb1e00 0x400d30f3:0x3ffb1f70 0x400d180e:0x3ffb1f90 0x400e5409:0x3ffb1fb0 0x4008b916:0x3ffb1fd0


ets Jun 8 2016 00:22:57

rst:0xc (SW_CPU_RESET),boot:0x1b (SPI_FAST_FLASH_BOOT)

configsip: 0, SPIWP:0xee


mode:DOUT, clock div:1





entry 0x400806a8

[MSG:Using machine:XY DLC32]

exit test mode

Grbl 1.1 [‘$’ for help]

Your Grbl may not support Variable Power mode (M4)

If your laser does not turn off between cuts,

switch to the GRBL-M3 device

Grbl 1.1 [‘$’ for help]

That looks similar to the firmware issue that was in the earlier versions. But this usually did not affect the functionality. Does the LED light up? I just tested the same type of limit switch you used and noticed that the connector is very lose and it was very fiddly to get it connected so that the LED lights up when pressed. Then its working. I suggest to update the firmware to the version I have here before going on: Firmware Update & Settings - Diode Laser Wiki (to exclude the core panic error).

right, connector is loose, but diode works good. Okay, i try to update firmware and see what happend

not working. Anyway thanks for help. I do not have a time for trying to do it and swithes are in scrap box now.

I put the switches to a scrap box but… i tried one solution from yt and cut one pin from switches. This metod is working. I know that it is not recommended, but problem has been solved. I hope it will no generate more problems.

Odd. But glad you got something that’s working. Hopefully not a sign of something else wrong.

If you have the same problem and will find this post, it is possible to try solution below:

I found a solution on yt, check it and it is working, but i do not know other konsequences of cutting pin.

So, if you use the same limit switch, you must cut 3rd pin. I marked it on a photo.
I know that sculpfun is preparing a dedicated limit switches, but before it will be available to buy, you can try this.

Thanks for sharing. But this should usually not be the case. I have exactly those switches, and they work as expected without cutting the wire.

Here is my theory: since most of these switches are clones from the original design, there might be some of them that have an incorrect board layout? This could be the reason… I think that is hard to find out…