Sculpfun S6 Pro on Mac with High Sierra 10.13.6 doesn't see laser - Solved

Update: Solution was to manually add and follow instructions shared in the response.

Trying to setup my S6 Pro connected to an older MacBook Pro. Downloaded CH340 Driver - used tried multiple versions with no luck. Laser does react (jolts slightly) when LightBurn searches for it but won’t show it in the discovery window.

I’m at a loss on what to do. Here’s where I downloaded the driver: CH340 Drivers for Windows, Mac and Linux

I tried V1.5 first without luck then went through the uninstall process and tried 1.4 and 1.3 - none seemed to work.

Is there a way to manually connect and calibrate the laser?

Any solution or setup suggestions welcome.


Start with this and click on the green solution:

If that doesn’t solve it there are other avenues to pursue.

1 Like

Thanks for the reply. I did a manual add and it worked. I heard others say “find my laser” is problematic on macs. Was able to do a successful project today.

1 Like